[Debian] codelite_exec: not found

CodeLite installation/troubleshooting forum
bitcode
CodeLite Curious
Posts: 8
Joined: Fri Dec 04, 2015 10:44 pm
Genuine User: Yes
IDE Question: C++
Contact:

[Debian] codelite_exec: not found

Post by bitcode » Fri Dec 04, 2015 10:54 pm

Hi, I couldn't find an answer on other threads.

I'm new to linux and I just installed Debian, codelite and gcc (on a virtualbox virtual machine). I tried to run the hello world and I got this error (see attachment).

I tried using codelite's own terminal but the same problem happened.

Thanks in advance.
You do not have the required permissions to view the files attached to this post.

bitcode
CodeLite Curious
Posts: 8
Joined: Fri Dec 04, 2015 10:44 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: [Debian] codelite_exec: not found

Post by bitcode » Sat Dec 05, 2015 12:57 am

UPDATE: PROBLEM SOLVED

I needed to install "make" in order to build my project. This solved the problem:

sudo apt-get install build-essential

Thanks anyways!

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: [Debian] codelite_exec: not found

Post by eranif » Sat Dec 05, 2015 9:39 am

BTW, this looks like an old version of CodeLite.
You should upgrade to version 9.0 at least...
http://downloads.codelite.org/

Eran
Make sure you have read the HOW TO POST thread

bitcode
CodeLite Curious
Posts: 8
Joined: Fri Dec 04, 2015 10:44 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: [Debian] codelite_exec: not found

Post by bitcode » Tue Dec 08, 2015 10:31 pm

Hey Eran

I updated CodeLite on my virtual machine. Thanks for reminding me!

Now, on my Windows machine, I have another problem. I'm using boost::asio library for network stuff. And I noticed that CodeLite freezes for a few seconds when trying to suggest function names/etc. If you check the file I attached, you'll see that the box showing the suggestion "unsigned" is showing up properly. However, It took approximately 20 seconds for it to appear. I was stuck for 20 seconds waiting for the box to find the suggestions and show them on the screen.

This problem happens gradually. When I first added boost::asio to the project, it was working fine. A couple of hours later this problem started happening. I restarted the IDE and the issue was not solved.

The IDE version I'm using in this example is 9.0.4.

Do you have any idea how can I solve this?

Thanks in advance.
You do not have the required permissions to view the files attached to this post.

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: [Debian] codelite_exec: not found

Post by eranif » Tue Dec 08, 2015 10:49 pm

I really have no clue... you can enable the logging of CodeLite and see what it is doing:
Settings->Preferences->Misc->Log->CodeLIte's log-file verbosity->Debug

Once enabled, try to reproduce the lag and attached the file

Code: Select all

%appdata%\CodeLIte\codelite.log
to this post


Eran
Make sure you have read the HOW TO POST thread

bitcode
CodeLite Curious
Posts: 8
Joined: Fri Dec 04, 2015 10:44 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: [Debian] codelite_exec: not found

Post by bitcode » Tue Dec 08, 2015 11:37 pm

Eran, I did what you say and selected "Debug" as the verbosity of the log, but that log did not return any data when I reproduced the bug. However, I changed the verbosity to "Developer" and I got really interesting results. If you check the attachment, you will note that as soon as I type "uns" some mysql queries start to run very fast, but it freezes in this line:

[ 17:25:05:829 DVL ] [CACHED ITEMS] select * from tags where scope in('boost') AND name LIKE 'uns%%' ESCAPE '^' LIMIT 1
[ 17:25:38:990 DVL ] [CACHED ITEMS] select * from tags where path='<global>' LIMIT 500

This query runs for 33 seconds:

Code: Select all

select * from tags where scope in('boost')  AND  name LIKE 'uns%%' ESCAPE '^'  LIMIT 1
I also want to clarify something: this issue happens with other keywords as well. For example: I have a variable called "file_name", and every time I type "fi" the IDE freezes for several seconds. It also freezes when I try to type "int" -- it freezes on "in".

Thanks.
You do not have the required permissions to view the files attached to this post.

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: [Debian] codelite_exec: not found

Post by eranif » Wed Dec 09, 2015 10:02 am

The logs are misleading here, it does not give an indication about when it 'starts' and when it 'ends'
I added some more log entries to give a more precise picture

Which OS are you using?

Eran
Make sure you have read the HOW TO POST thread

bitcode
CodeLite Curious
Posts: 8
Joined: Fri Dec 04, 2015 10:44 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: [Debian] codelite_exec: not found

Post by bitcode » Wed Dec 09, 2015 11:44 am

Hi, Eran

I'm using Windows 7.

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: [Debian] codelite_exec: not found

Post by eranif » Wed Dec 09, 2015 1:03 pm

Make sure you have read the HOW TO POST thread

bitcode
CodeLite Curious
Posts: 8
Joined: Fri Dec 04, 2015 10:44 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: [Debian] codelite_exec: not found

Post by bitcode » Wed Dec 09, 2015 10:35 pm

Eran,

I tested with the version 9.0.6. The problem persists. (attachment codelite00.txt)

However if I create a new source file and paste the code from the old file in the new file, the problem will not happen at first (but it may start to happen a few moments later).

I attached the log (codelite01.log) of the new file (the one where the problem does not happen at first).

In short:

codelite00.log - log of the problem happening in the old file (file that we have been testing since the beginning of this post).
codelite01.log - log of the problem NOT happening in a new file where I pasted the code from the old file.

Let me know if you need more information.

Thanks
You do not have the required permissions to view the files attached to this post.

Post Reply