Errors after building

CodeLite installation/troubleshooting forum
RainMaker
CodeLite Curious
Posts: 2
Joined: Tue Nov 17, 2015 1:38 am
Genuine User: Yes
IDE Question: c++
Contact:

Errors after building

Post by RainMaker » Tue Nov 17, 2015 2:44 am

Hello there,

I'm moving from codeblocks and I'm checking out codelite. I use wxWidgets 3.0.2 and mingw 4.7.1. I compiled wxwidgets myself and I used this with no problems in the other codeblocks projects.

I just started using codelite 9.0.3 to compare it to codeblocks with wxSmith. So far I like better the livelier community activity of codelite, and the interface is a lot clearer.

Well, my problem is that I just opened the IDE, configured my settings with the wizard and I created a test dummy project (several actually) of wxwidget GUI exec with wxCrafter in which I add a button and each time I build it (them) I get this message:

Debugger exited with the following error string:
"During startup program exited with code 0xc0000135"

My env variables in codelite are as follows:

Code: Select all

CodeLiteDir=C:\Program Files\CodeLite
WXWIN=C:\libs\wxWidgets-3.0.2
WXCFG=gcc_dll\mswu
PATH=C:\libs\MinGW4.7CodeBlocks\bin;$PATH
I have a similar log for each time I try to run the project.

Thanks in advace!!

Code: Select all

C:\Windows\system32\cmd.exe /C C:/libs/MinGW/bin/mingw32-make.exe -j4 SHELL=cmd.exe -e -f  Makefile
"----------Building project:[ helloGUI - Debug ]----------"
mingw32-make.exe[1]: Entering directory 'C:/Users/Jesus/Documents/DesarrolloSoftware/helloGUI'
C:/libs/MinGW/bin/windres.exe -i "C:/Users/Jesus/Documents/DesarrolloSoftware/helloGUI/win_resources.rc" --use-temp-file --define __WXMSW__ --define _UNICODE --include-dir C:/libs/wxWidgets-3.0.2/lib/gcc_dll/mswu --include-dir C:/libs/wxWidgets-3.0.2/include --define WXUSINGDLL    -o ./Debug/win_resources.rc.o
C:/libs/MinGW/bin/g++.exe  -c  "C:/Users/Jesus/Documents/DesarrolloSoftware/helloGUI/wxcrafter.cpp" -g -O0 -Wall -mthreads -DHAVE_W32API_H -D__WXMSW__ -D__WXDEBUG__ -D_UNICODE -IC:/libs/wxWidgets-3.0.2/lib/gcc_dll/mswud -IC:/libs/wxWidgets-3.0.2/include -DWXUSINGDLL -Wno-ctor-dtor-privacy -pipe -fmessage-length=0     -o ./Debug/wxcrafter.cpp.o -I. -I.
C:/libs/MinGW/bin/g++.exe  -c  "C:/Users/Jesus/Documents/DesarrolloSoftware/helloGUI/wxcrafter_bitmaps.cpp" -g -O0 -Wall -mthreads -DHAVE_W32API_H -D__WXMSW__ -D__WXDEBUG__ -D_UNICODE -IC:/libs/wxWidgets-3.0.2/lib/gcc_dll/mswud -IC:/libs/wxWidgets-3.0.2/include -DWXUSINGDLL -Wno-ctor-dtor-privacy -pipe -fmessage-length=0     -o ./Debug/wxcrafter_bitmaps.cpp.o -I. -I.
C:/libs/MinGW/bin/g++.exe  -c  "C:/Users/Jesus/Documents/DesarrolloSoftware/helloGUI/MainDialog.cpp" -g -O0 -Wall -mthreads -DHAVE_W32API_H -D__WXMSW__ -D__WXDEBUG__ -D_UNICODE -IC:/libs/wxWidgets-3.0.2/lib/gcc_dll/mswud -IC:/libs/wxWidgets-3.0.2/include -DWXUSINGDLL -Wno-ctor-dtor-privacy -pipe -fmessage-length=0     -o ./Debug/MainDialog.cpp.o -I. -I.
C:/libs/MinGW/bin/windres.exe: warning: 24: 1: 1033: duplicate value
C:/libs/MinGW/bin/g++.exe  -c  "C:/Users/Jesus/Documents/DesarrolloSoftware/helloGUI/main.cpp" -g -O0 -Wall -mthreads -DHAVE_W32API_H -D__WXMSW__ -D__WXDEBUG__ -D_UNICODE -IC:/libs/wxWidgets-3.0.2/lib/gcc_dll/mswud -IC:/libs/wxWidgets-3.0.2/include -DWXUSINGDLL -Wno-ctor-dtor-privacy -pipe -fmessage-length=0     -o ./Debug/main.cpp.o -I. -I.
C:/libs/MinGW/bin/g++.exe -o ./Debug/helloGUI @"helloGUI.txt" -L.    -mthreads -LC:/libs/wxWidgets-3.0.2/lib/gcc_dll -lwxmsw30ud -lwxscintillad -lwxtiffd -lwxjpegd -lwxpngd -lwxzlibd -lwxregexud -lwxexpatd -lkernel32 -luser32 -lgdi32 -lcomdlg32 -lwxregexud -lwinspool -lwinmm -lshell32 -lcomctl32 -lversion -lshlwapi -lole32 -loleaut32 -luuid -lrpcrt4 -ladvapi32 -lwsock32  -mwindows
mingw32-make.exe[1]: Leaving directory 'C:/Users/Jesus/Documents/DesarrolloSoftware/helloGUI'
====0 errors, 0 warnings====

User avatar
eranif
CodeLite Plugin
Posts: 6120
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Errors after building

Post by eranif » Tue Nov 17, 2015 8:29 am

This error usually means that your application can't find a DLL(s). My guess: the wxWidgets _debug_ DLLs


You should add the path to wxWidgets binaries, so your PATH environment variable should be set to (settings->environment variables):

Code: Select all

PATH=C:\libs\MinGW4.7CodeBlocks\bin;C:\libs\wxWidgets-3.0.2\lib\gcc_dll;$PATH
BTW, running Ctrl-F5 (run the project) would give you a Windows error message stating that "XYZ.dll is missing"

Eran
Make sure you have read the HOW TO POST thread

RainMaker
CodeLite Curious
Posts: 2
Joined: Tue Nov 17, 2015 1:38 am
Genuine User: Yes
IDE Question: c++
Contact:

Re: Errors after building

Post by RainMaker » Thu Nov 19, 2015 6:26 pm

Thanks to your guiding I got it to work. Actually I did have issues with the PATH variable. There was the problem with the wxwidgets directory but also with the compiler. When I followed the wizard to create the dummies, I always chose the previous MinGW(4.7) for Codeblocks instead of the MinGW(4.8) that I had downloaded just to compile wxwidgets.

Again and again Thank you Eran!

Post Reply