Keyboard Issue- Can't insert # Linux (swiss keyboard)

CodeLite installation/troubleshooting forum
sdallo
CodeLite Curious
Posts: 2
Joined: Fri Feb 13, 2015 5:25 pm
Genuine User: Yes
IDE Question: c++
Contact:

Keyboard Issue- Can't insert # Linux (swiss keyboard)

Post by sdallo » Fri Feb 13, 2015 5:36 pm

Hi

I really like codelite as ide and on my windows box everything works fine, but on my Linux Box the chars on the numbers keys (not number block)
which requires to press "alt gr" and for example the number 3 (#) won't appear in the editor. That is really annoying for c++ programming :-) The same for the following characters "| @ ¬ | ¢ ' ~", this chars are all the third possible char for the corresponding number key.
Please can anyone help me to solve that problem?

I use
Linux Mint 64 bit
Swiss German Keyboard Layout
Codelite 7.0

EDIT: Somehow it is related to this bug https://github.com/eranif/codelite/comm ... 7d8853932a as stated in that thread, I disabled the external tools shortcut's. I think this problem will affect a lot of peoples which uses european keyboard layouts.

Cheers,
Sandro

User avatar
eranif
CodeLite Plugin
Posts: 6141
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Keyboard Issue- Can't insert # Linux (swiss keyboard)

Post by eranif » Fri Feb 13, 2015 6:23 pm

sdallo wrote:EDIT: Somehow it is related to this bug https://github.com/eranif/codelite/comm ... 7d8853932a as stated in that thread, I disabled the external tools shortcut's. I think this problem will affect a lot of peoples which uses european keyboard layouts.
Yes, I fixed this bug today. As you discovered the workaround is simple as stated in the bug report

Eran
Make sure you have read the HOW TO POST thread

User avatar
eranif
CodeLite Plugin
Posts: 6141
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Keyboard Issue- Can't insert # Linux (swiss keyboard)

Post by eranif » Fri Feb 13, 2015 6:24 pm

sdallo wrote:EDIT: Somehow it is related to this bug https://github.com/eranif/codelite/comm ... 7d8853932a as stated in that thread, I disabled the external tools shortcut's. I think this problem will affect a lot of peoples which uses european keyboard layouts.
Yes, I fixed this bug today. As you discovered, the workaround is simple as stated in the bug report
For clarifications and for other people who may came across this thread: to workaround this bug you can
  • Disable the external tools plugin from: Plugins->Manage plugins and uncheck the external tools plugin
  • OR: remap the external tools plugin keyboard shortcuts to something other than Ctrl-Alt from the main menu: Settings->Keyboard shortcuts->Plugins->External tools
Eran
Make sure you have read the HOW TO POST thread

sdallo
CodeLite Curious
Posts: 2
Joined: Fri Feb 13, 2015 5:25 pm
Genuine User: Yes
IDE Question: c++
Contact:

Re: Keyboard Issue- Can't insert # Linux (swiss keyboard)

Post by sdallo » Fri Feb 13, 2015 6:31 pm

Hi Eran

Thank you for you quick response. I'm so sorry that I discovered that thread after my post and so started another topic on that.
Once again really nice IDE thanks a lot for your efforts.

Cheers,
Sandro

Post Reply