Can't use paths in build settings

CodeLite installation/troubleshooting forum
Absinthe
CodeLite Curious
Posts: 1
Joined: Wed Jul 16, 2014 10:55 pm
Genuine User: Yes
IDE Question: c++
Contact:

Can't use paths in build settings

Post by Absinthe » Wed Jul 16, 2014 11:05 pm

I am using CodeLite 6 under windows 7 and I am attempting to use the MinGW compiler set.

If I add MinGW/bin to my windows path I can set all the tools to their bare names (e.g. g++.exe, gcc.exe, ld.exe etc.) it works fine

However, if I leave then with paths (e.g c:\MinGW\bin\g++.exe , C:\MinGW\bin\gcc.exe, C:\MinGW\bin\ld.exe etc.) then the build says that
it can't find CMinGWbing++ or something like that. It also suggests that the message is coming from /bin/sh which I am not sure where it is getting that, as my ComSpec is cmd.exe.

Currently, I am working around the issue with the path thing, but eventually I want to be able to detect and change these tool chains.

Suggestions?

User avatar
eranif
CodeLite Plugin
Posts: 6120
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Can't use paths in build settings

Post by eranif » Thu Jul 17, 2014 9:27 am

This will be fixed out of the box in codelite 6.1

For now, do this, from the main menu:
Settings->Build Settings->Compilers-><Your Compiler>->Tools
Under the "MAKE" tool, add this:

Code: Select all

SHELL=CMD.EXE
For example, if your MAKE tool is set to:

Code: Select all

C:/MinGW-4.8.1/bin/mingw32-make.exe -j8 
It should now be set to:

Code: Select all

C:/MinGW-4.8.1/bin/mingw32-make.exe -j8 SHELL=cmd.exe 
This will fix this.

The reason for this, is because you have somewhere in your path sh.exe, and mingw32-make is trying to use it

Eran
Make sure you have read the HOW TO POST thread

Post Reply