problems instaling codelite from your repos debian

CodeLite installation/troubleshooting forum
tuxd3v
CodeLite Curious
Posts: 2
Joined: Wed Oct 23, 2013 10:51 am
Genuine User: Yes
IDE Question: c++
Contact:

problems instaling codelite from your repos debian

Post by tuxd3v » Wed Oct 23, 2013 11:05 am

Hi, guys,

I am searching for a managed IDE for C Language but with low features.
-------------------------------------------
updated my sources.lst with deb http://repos.codelite.org/debian/ wheezy contrib
-------------------------------------------
preferences with
Package: *
Pin: origin repos.codelite.org
Pin-Priority: 700
------------------------------------------
debian have a very old version 2.xx, even on testing :S

I added your key

I made en update on sources...

but when i try to install I got an error...I suspect your repos are...or offline or with problems :(

sudo apt-cache search codelite
codelite-plugins - Powerful and lightweight C/C++ IDE - plugins
codelite - cross-platform C/C++ IDE
codelite-dbg - Debug symbols for CodeLite
wxcrafter - gui generator plugin for codelite

-------------------------------------------------
sudo apt-get install codelite
The following packages have unmet dependencies:
codelite : Depends: libgnomeprint2.2-0 (>= 2.17.0) but it is not installable
Depends: libgnomeprintui2.2-0 (>= 2.17.0) but it is not installable
E: Unable to correct problems, you have held broken packages.
------------------------------------------------
sudo apt-cache policy codelite (the version prefered is the codelite repos version)
codelite:
Installed: (none)
Candidate: 5.3-1.wheezy
Version table:
5.3-1.wheezy 0
700 http://repos.codelite.org/debian/ wheezy/contrib amd64 Packages
2.8.0.4537~dfsg-4 0
500 http://mirror.rts-informatique.fr/linux ... an/latest/ testing/main amd64 Packages
----------------------------------------------
is this a cache conflict with the prior cache content of the apt system?

can any one help me with that?is your repos up?

Thanks in advance

regards
tuxd3v

DavidGH
CodeLite Plugin
Posts: 667
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: problems instaling codelite from your repos debian

Post by DavidGH » Wed Oct 23, 2013 1:11 pm

Hi,
but when i try to install I got an error...I suspect your repos are...or offline or with problems
It works for me now.
Why did you think it was off-line? The problem you tell us about: 'The following packages have unmet dependencies' is not an issue with repos.codelite.org; it's something missing from the debian repos that you are looking in.

libgnomeprintui is a dependency of wxWidgets, the toolkit with which CodeLite is built. (It's actually not used there either, and I believe it'll be removed in the next release.) It is available in the wheezy repos, in the 'oldlibs' section.

I suggest you check your sources.lst, making sure you've not commented out any likely-looking repos. If that fails, are you using standard ones (e.g. ftp.uk.debian.org/debian/) or one of the mirrors? If a mirror, maybe it's not complete.

Regards,

David

pavel.iqx
CodeLite Enthusiast
Posts: 19
Joined: Wed Jun 26, 2013 12:46 pm
Genuine User: Yes
IDE Question: c++
Contact:

Re: problems instaling codelite from your repos debian

Post by pavel.iqx » Wed Oct 23, 2013 6:12 pm

@tuxd3v:
did you try just installing libgnomeprint2.2-0 manualy?
I do it whenever apt "get stuck" this way...
Debian GNU/Linux 7.3 (wheezy) x64; CodeLite 5.4 from repo & CodeLite self-compiled from git HEAD

tuxd3v
CodeLite Curious
Posts: 2
Joined: Wed Oct 23, 2013 10:51 am
Genuine User: Yes
IDE Question: c++
Contact:

Re: problems instaling codelite from your repos debian

Post by tuxd3v » Wed Oct 23, 2013 8:24 pm

Hi guys,

thanks for the help ;)

I can't find the packages in Mint LMDE amd64(Testing):
libgnomeprint2.2-0
libgnomeprintui2.2-0

even a search for their names, don't return any results...
libgnomeprint
libgnomeprintui

I don know where to find this packages...

The problem is that apt will get the codelite from your repos, but before it makes a dependency check, in the rest of my repos...and it can't resolve the dependencies, so it gives me the error:

sudo apt-get install codelite

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
codelite : Depends: libgnomeprint2.2-0 (>= 2.17.0) but it is not installable
Depends: libgnomeprintui2.2-0 (>= 2.17.0) but it is not installable
E: Unable to correct problems, you have held broken packages.

In the way your package is built i need that two libraries, at least(of course it will need a lot more...and maybe will brake in another dependencies elsewhere).

I removed the aptpin fo codelite repo... but mantaining the source repo in sources.lst, the problem continues

My sources.lst
deb http://packages.linuxmint.com/ debian main upstream import
deb http://mirror.rts-informatique.fr/linux ... ian/latest testing main contrib non-free
deb http://mirror.rts-informatique.fr/linux ... t/security testing/updates main contrib non-free
deb http://mirror.rts-informatique.fr/linux ... multimedia testing main non-free
deb http://repos.codelite.org/debian/ wheezy contrib

How do you solved the problem?

thanks for the help

regards
tux

pavel.iqx
CodeLite Enthusiast
Posts: 19
Joined: Wed Jun 26, 2013 12:46 pm
Genuine User: Yes
IDE Question: c++
Contact:

Re: problems instaling codelite from your repos debian

Post by pavel.iqx » Wed Oct 23, 2013 9:47 pm

So... the problem is that testing doesn't include these packages... http://packages.debian.org/search?suite ... print2.2-0 and you are using wheezy's codelite...

I'm glad (selfishly) where is CL for wheezy, 'cause i'm using it, but debian testing is always more recent.

From my point of view, you have two options: either try CL repo for an ubuntu or just add missing packages also from wheezy. Both are hack, but it works so :) In your place, I will try the second choice.
Debian GNU/Linux 7.3 (wheezy) x64; CodeLite 5.4 from repo & CodeLite self-compiled from git HEAD

User avatar
eranif
CodeLite Plugin
Posts: 6091
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: problems instaling codelite from your repos debian

Post by eranif » Wed Oct 23, 2013 9:57 pm

pavel.iqx wrote:From my point of view, you have two options:
A third option is build codelite yourself. Its pretty easy especially on Debian
http://codelite.org/Developers/Linux#toc2

Eran
Make sure you have read the HOW TO POST thread

pavel.iqx
CodeLite Enthusiast
Posts: 19
Joined: Wed Jun 26, 2013 12:46 pm
Genuine User: Yes
IDE Question: c++
Contact:

Re: problems instaling codelite from your repos debian

Post by pavel.iqx » Wed Oct 23, 2013 10:15 pm

Sorry I missed that, you are right.
But git no longer contains wxCrafter, so tuxd3v can use the one from wheezy repo. As i can see, wxCrafter package has no dependency. Am i correct?
Debian GNU/Linux 7.3 (wheezy) x64; CodeLite 5.4 from repo & CodeLite self-compiled from git HEAD

DavidGH
CodeLite Plugin
Posts: 667
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: problems instaling codelite from your repos debian

Post by DavidGH » Wed Oct 23, 2013 10:31 pm

tuxd3v can use the one from wheezy repo. As i can see, wxCrafter package has no dependency. Am i correct?
It does have dependencies of course, but nothing extra to CodeLite itself. So there's a good chance that the wheezy one will work.

If apt won't install it, you can download it direct (see http://codelite.org/LiteEditor/Repositories#toc4) and use dpkg; or else download the ingredients (http://codelite.org/LiteEditor/Repositories#toc5) and install them by hand.

Post Reply