Setting environment variables problem

General questions regarding the usage of CodeLite
uwave
CodeLite Curious
Posts: 3
Joined: Thu Aug 15, 2013 4:50 am
Genuine User: Yes
IDE Question: C++
Contact:

Setting environment variables problem

Post by uwave » Thu Aug 15, 2013 5:00 am

New user here.

I am attempting to compile a large C project.

I set the required environment variables @ settings>>Environment Variables

I created a new environment set called "ATN" and added my environment variables to it.

Under project settings, the "Environment variable set to use" is set to"ATN".


I get several compiler errors when building the project because the environment variables are not being seen (multiple definitions of structs and variables)



What is wrong here?

Jarod42
CodeLite Expert
Posts: 176
Joined: Wed Sep 30, 2009 5:54 pm
Genuine User: Yes
IDE Question: C++
Location: France
Contact:

Re: Setting environment variables problem

Post by Jarod42 » Thu Aug 15, 2013 6:29 am

Where do you use environment variables and for what purpose ?

Did you want to use Preprocessor (defines) instead ? (in Project settings:Common setting>Compiler).

uwave
CodeLite Curious
Posts: 3
Joined: Thu Aug 15, 2013 4:50 am
Genuine User: Yes
IDE Question: C++
Contact:

Re: Setting environment variables problem

Post by uwave » Thu Aug 15, 2013 7:48 am

That is answer.

Thank you Jarod42.

You are right.

I could not find "preprocessor" anywhere -i thought maybe Codelite was referring preprocessor definitions as environment vars.

I also mistook "workspace settings" for "project settings".....

Too many tabs..... I suppose I should just explore every tab and "see what is under every rock".


BTW, do you know where to set runtime arguments for the debugger?

uwave
CodeLite Curious
Posts: 3
Joined: Thu Aug 15, 2013 4:50 am
Genuine User: Yes
IDE Question: C++
Contact:

Re: Setting environment variables problem

Post by uwave » Thu Aug 15, 2013 8:02 am

I found it.

right click on project in the workspace tab>>settings>>Common Settings>>General

Post Reply