Help! Codelite upgraded from 4.0 to 4.1 now won't run

CodeLite installation/troubleshooting forum
zaphod
CodeLite Enthusiast
Posts: 45
Joined: Fri Sep 11, 2009 6:20 pm
Contact:

Help! Codelite upgraded from 4.0 to 4.1 now won't run

Post by zaphod » Fri Aug 31, 2012 6:21 pm

I'm using Ubuntu Maverick 10.10 and just upgraded Codelite from v4.0.5589 to v4.1.5770
Codelite no longer launches. :o
The 'hourglass' simply spins for a while and then stops.
I don't want to move to a more recent Ubuntu release because I have 10.10 deployed on many machines.

User avatar
eranif
CodeLite Plugin
Posts: 5895
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Help! Codelite upgraded from 4.0 to 4.1 now won't run

Post by eranif » Fri Aug 31, 2012 6:25 pm

which package did you use for the installation? AFAIR, we dont provide Maverick binaries...

What errors do you get when you try to launch codelite from the command line?

Eran
Make sure you have read the HOW TO POST thread

zaphod
CodeLite Enthusiast
Posts: 45
Joined: Fri Sep 11, 2009 6:20 pm
Contact:

Re: Help! Codelite upgraded from 4.0 to 4.1 now won't run

Post by zaphod » Fri Aug 31, 2012 6:41 pm

From the command line:
codelite: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by codelite)
codelite: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib/codelite/libpluginu.so)
codelite: /lib/libc.so.6: version `GLIBC_2.15' not found (required by /usr/lib/codelite/libcodeliteu.so)
codelite: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib/codelite/libcodeliteu.so)

I have been merrily rolling along upgrading Codelite whenever there has been a new release, even though I have been 'stuck' at 10.10
What do you recommend?

User avatar
eranif
CodeLite Plugin
Posts: 5895
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Help! Codelite upgraded from 4.0 to 4.1 now won't run

Post by eranif » Fri Aug 31, 2012 6:48 pm

I suggest to build coedelite from sources.
Under ubuntu its an easy task

Follow these steps (pretty straight forward):

http://codelite.org/Developers/Linux

Eran
Make sure you have read the HOW TO POST thread

zaphod
CodeLite Enthusiast
Posts: 45
Joined: Fri Sep 11, 2009 6:20 pm
Contact:

Re: Help! Codelite upgraded from 4.0 to 4.1 now won't run

Post by zaphod » Fri Aug 31, 2012 6:54 pm

I think I have boxed myself in:

The following packages have unmet dependencies:
libgtk2.0-dev : Depends: libglib2.0-dev (>= 2.25.8) but it is not going to be installed
Depends: libgdk-pixbuf2.0-dev (>= 2.21.0) but it is not going to be installed
Depends: libpango1.0-dev (>= 1.20) but it is not going to be installed
Depends: libatk1.0-dev (>= 1.29.2) but it is not going to be installed
Depends: libcairo2-dev (>= 1.6.4-6.1) but it is not going to be installed
libwxgtk2.8-dev : Depends: libwxgtk2.8-0 (= 2.8.11.0-0ubuntu4) but 2.8.11.0-0ubuntu4.1 is to be installed
Depends: libwxbase2.8-dev (= 2.8.11.0-0ubuntu4) but it is not going to be installed
E: Broken packages

So building from source introduces yet more dependencies that are out of date.

User avatar
eranif
CodeLite Plugin
Posts: 5895
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Help! Codelite upgraded from 4.0 to 4.1 now won't run

Post by eranif » Fri Aug 31, 2012 7:01 pm

Did you make sure you are up-to-date?
I found several posts on google..

Here is one suggestion:
http://askubuntu.com/questions/111976/o ... pendencies

Eran
Make sure you have read the HOW TO POST thread

zaphod
CodeLite Enthusiast
Posts: 45
Joined: Fri Sep 11, 2009 6:20 pm
Contact:

Re: Help! Codelite upgraded from 4.0 to 4.1 now won't run

Post by zaphod » Fri Aug 31, 2012 7:16 pm

I just ran:
sudo apt-get update
but that hasn't helped

Do you have a suggestion how I might readily roll back Codelite to 4.0?

I'm not ready to mess too much with my main development machine.
I'm beginning to think I should move forward to 12.0 but I need to do it in a orderly fashion by bringing up a test machine first.

User avatar
eranif
CodeLite Plugin
Posts: 5895
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Help! Codelite upgraded from 4.0 to 4.1 now won't run

Post by eranif » Fri Aug 31, 2012 7:26 pm

Which package did you try to install (the one that breaks codelite) ?

Have you tried installing the binaries that we package for ubuntu 11.10 ?

This is the 32 bit:
http://sourceforge.net/projects/codelit ... b/download

and 64 bit:
http://sourceforge.net/projects/codelit ... b/download

Eran
Make sure you have read the HOW TO POST thread

zaphod
CodeLite Enthusiast
Posts: 45
Joined: Fri Sep 11, 2009 6:20 pm
Contact:

Re: Help! Codelite upgraded from 4.0 to 4.1 now won't run

Post by zaphod » Fri Aug 31, 2012 7:48 pm

It (4.1 for Oneiric) too has unresolved dependencies.
The package I tried was the default that Codelite pointed me to on Sourceforge which I think was the 32bit i386 version 4.1.5770 for Ubuntu 12.04
My fear is that if I step toward 12.04 the resulting binaries I produce will no longer run on the many 10.10 machines
I have so the upgrading process is a much bigger job that I'm ready to do quite yet!

I'm afraid that things were not broken and I have 'fixed' them.

zaphod
CodeLite Enthusiast
Posts: 45
Joined: Fri Sep 11, 2009 6:20 pm
Contact:

Re: Help! Codelite upgraded from 4.0 to 4.1 now won't run

Post by zaphod » Fri Aug 31, 2012 8:26 pm

Good news!
I found I had not deleted the 4.0 deb package download: 4.0.5589-ubuntu0-11.10 from June 9th this year.
I uninstalled 4.1 and re-installed 4.0
I'm back at square one, thank goodness.
I need to step forward, but with more care. I have blithely upgraded Codelite many times all the while knowing that I was running an old OS version.
I have been getting away with it up till now.

Eran, thanks for your help. And thank you for Codelite.

Post Reply