Compiled program execution error on linux

CodeLite installation/troubleshooting forum
User avatar
LeetShiva
CodeLite Enthusiast
Posts: 20
Joined: Wed Mar 14, 2012 6:39 pm
Genuine User: Yes
IDE Question: C++
Contact:

Compiled program execution error on linux

Post by LeetShiva » Wed Mar 14, 2012 6:45 pm

I get this error when I try to run compiled helloworld program on my Debian Linux machine.
I have used till now a 2.8 version of codelite but now after update to 3.5 version I get a error anyone can help track the problem?
I'm running amd64 linux
linux 3.1 amd64

I get this error:

Running program: /usr/lib/codelite/codelite_xterm './CppTwoDimmensional ' '/bin/sh -f /usr/bin/codelite_exec ./CppTwoDimmensional '
Program exited with return code: -1

the program was simple starting helloworld that have compiled but not running ?
Last edited by LeetShiva on Wed Mar 14, 2012 7:40 pm, edited 1 time in total.

User avatar
LeetShiva
CodeLite Enthusiast
Posts: 20
Joined: Wed Mar 14, 2012 6:39 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Compiled program execution error on linux

Post by LeetShiva » Wed Mar 14, 2012 6:51 pm

I had simmilar error when I was tryin to install version 3.0 !
I guess that codelite is made also for ubuntu and debian but sense is .deb it should install fine on debian and its installed fine just throw error when it should execute program.

GabiLaser
CodeLite Enthusiast
Posts: 14
Joined: Wed Feb 16, 2011 6:07 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Compiled program execution error on linux

Post by GabiLaser » Thu Mar 15, 2012 12:18 am

You'll have to install xterm, or go into CodeLite preferences and select other program to run instead of codelite_xterm (which calls xterm internally).

User avatar
LeetShiva
CodeLite Enthusiast
Posts: 20
Joined: Wed Mar 14, 2012 6:39 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Compiled program execution error on linux

Post by LeetShiva » Thu Mar 15, 2012 8:34 am

Ofcourse that I have installed xterm and I tried to put the line like:
xterm '$(TITLE)' '$(CMD)'
and
uxterm '$(TITLE)' '$(CMD)'
and
xfce4-terminal '$(TITLE)' '$(CMD)'
Neither one dont work it give me the same error ...

User avatar
LeetShiva
CodeLite Enthusiast
Posts: 20
Joined: Wed Mar 14, 2012 6:39 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Compiled program execution error on linux

Post by LeetShiva » Thu Mar 15, 2012 8:46 am

I tried to compile it and install and I get the same messages.
Maybe eran know what is it ?

DavidGH
CodeLite Plugin
Posts: 676
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: Compiled program execution error on linux

Post by DavidGH » Thu Mar 15, 2012 2:56 pm

Hi,

I use (and build) CodeLite on squeeze, and the latest versions work fine.

There's a small chance that there's a problem because you installed one of the ubuntu versions; though I'd have expected them to work on debian too, that's untested. You can install the squeeze package as described here.

However I suggest you first do the obvious check: look in the CppTwoDimmensional dir and check that there is a binary of that name to execute. If not, your build failed.
If it is present, try running it in a terminal. This is likely to give much more useful error messages (e.g. a shared lib not found, in which case you may need to set LD_LIBRARY_PATH).

Regards,

David

User avatar
LeetShiva
CodeLite Enthusiast
Posts: 20
Joined: Wed Mar 14, 2012 6:39 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Compiled program execution error on linux

Post by LeetShiva » Thu Mar 15, 2012 7:48 pm

DavidGH wrote:Hi,

I use (and build) CodeLite on squeeze, and the latest versions work fine.

There's a small chance that there's a problem because you installed one of the ubuntu versions; though I'd have expected them to work on debian too, that's untested. You can install the squeeze package as described here.

However I suggest you first do the obvious check: look in the CppTwoDimmensional dir and check that there is a binary of that name to execute. If not, your build failed.
If it is present, try running it in a terminal. This is likely to give much more useful error messages (e.g. a shared lib not found, in which case you may need to set LD_LIBRARY_PATH).

Regards,

David
It runs from terminal thx I'll try to install debian package 3.5 :) I have installed latest in debian before that was 2.8.
I'll try with 3.5 and tell you if it work. :)

User avatar
LeetShiva
CodeLite Enthusiast
Posts: 20
Joined: Wed Mar 14, 2012 6:39 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Compiled program execution error on linux

Post by LeetShiva » Thu Mar 15, 2012 8:01 pm

What version is in the repo ?
I still get version 2.8 as highest version in debian repo ?

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Compiled program execution error on linux

Post by eranif » Fri Mar 16, 2012 1:36 pm

LeetShiva wrote:I still get version 2.8 as highest version in debian repo ?
This is the official debian repository - so I guess there is nothing we can do about it...

You could try and use codelite's repository maintained by our own DavidGH ;)
http://www.codelite.org/LiteEditor/Repositories

Eran
Make sure you have read the HOW TO POST thread

User avatar
LeetShiva
CodeLite Enthusiast
Posts: 20
Joined: Wed Mar 14, 2012 6:39 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Compiled program execution error on linux

Post by LeetShiva » Fri Mar 16, 2012 3:51 pm

What version to choose from https://sourceforge.net/projects/codeli ... elite-3.5/

I gues I should try GTK version cause I already tried ubuntu version and it do not work.

Post Reply