Error: install wxWidgets and codelite under Fedora13

CodeLite installation/troubleshooting forum
blackwinter
CodeLite Curious
Posts: 2
Joined: Tue Dec 27, 2011 1:16 pm
Genuine User: Yes
IDE Question: c++
Contact:

Error: install wxWidgets and codelite under Fedora13

Post by blackwinter » Tue Dec 27, 2011 1:26 pm

Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6),
and wxQA used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6).

wxWidgets-2.8.12.tar.gz
codelite-3.0.0.5041.tar.gz
I build them form sourcecode.

User avatar
eranif
CodeLite Plugin
Posts: 6055
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Error: install wxWidgets and codelite under Fedora13

Post by eranif » Tue Dec 27, 2011 1:31 pm

blackwinter wrote:Fatal Error: Mismatch between the program and library build versions detected.
The library used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.6),
and wxQA used 2.8 (no debug,Unicode,compiler with C++ ABI 1002,wx containers,compatible with 2.4,compatible with 2.6).

wxWidgets-2.8.12.tar.gz
codelite-3.0.0.5041.tar.gz
I build them form sourcecode.
Make sure that during runtime codelite is using the wxWidgets that it was built against.

Also, try to provide more information (e.g. how did you build wxWidgets (configure line) + where did you install it etc)

Eran
Make sure you have read the HOW TO POST thread

blackwinter
CodeLite Curious
Posts: 2
Joined: Tue Dec 27, 2011 1:16 pm
Genuine User: Yes
IDE Question: c++
Contact:

Re: Error: install wxWidgets and codelite under Fedora13

Post by blackwinter » Tue Dec 27, 2011 1:42 pm

> cd home/workspace/wxWidgets-2.8.12
> mkdir buildgtk
> cd buildgtk
> ../configure --with-gtk --enable-unicode
> make
> su <type root password>
> make install

DavidGH
CodeLite Plugin
Posts: 635
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: Error: install wxWidgets and codelite under Fedora13

Post by DavidGH » Tue Dec 27, 2011 7:09 pm

Hi,

Do the wx samples build and run e.g. buildgtk/minimal? If so, your wxGTK-2.8.12 isn't the problem.

You didn't explain how you built CodeLite, but I wonder if you either compiled or linked (or both) against a different wxGTK, probably the fedora package one. Try doing:
ldd /path/to/your/binary/codelite
and in the output, look at the filepaths of the wx libraries.

One possibility is that you installed your wxGTK to /usr/local/, and there's a package wxGTK in /usr/. If so, it may be that fedora looks only, or looks first, for runtime libs in /usr/.

I never 'make install' my non-package wxGTK. Instead I configure:
../configure --with-gtk --enable-unicode --whatever --prefix=$(pwd)

This makes the wx build expect to be used from /path/to/buildgtk/ and links accordingly. You do then need either to hardwire your path-to-wx-config when building CodeLite, or else prepend it to your $PATH in that terminal.

Regards,

David

Post Reply