Project compiles but does not run

CodeLite installation/troubleshooting forum
XonX
CodeLite Curious
Posts: 2
Joined: Tue Sep 06, 2011 11:53 pm
Genuine User: Yes
IDE Question: C++
Contact:

Project compiles but does not run

Post by XonX » Wed Sep 07, 2011 12:01 am

Hello.
I've just installed codelite 2.8.0.4537 from my Linux distribution repo and compiled a test qmake project. It compiles fine and does not produce errors, but does not run.
Instead, a terminal window appears with

Code: Select all

/usr/lib/codelite/codelite_exec: 22: ProjectName: not found
written there.
I've located the compiled executable manually and it runs ok, producing the right output.

My os is Linux Mint11 x64

User avatar
eranif
CodeLite Plugin
Posts: 6120
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Project compiles but does not run

Post by eranif » Wed Sep 07, 2011 9:25 am

XonX wrote:/usr/lib/codelite/codelite_exec: 22: ProjectName: not found
It seems you have tempered with the project settings.

Make sure that "Project Settings | General | Program" is pointing to the correct executable for running.

Also note that the codelite's macros syntax is strict and must be in the form of: $(ProjectName) (including the braces)

Eran
Make sure you have read the HOW TO POST thread

XonX
CodeLite Curious
Posts: 2
Joined: Tue Sep 06, 2011 11:53 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Project compiles but does not run

Post by XonX » Thu Sep 08, 2011 5:07 pm

Well, I haven't tempered with the settings. Used the default ones.
But pointing it to the executable helped. Thank you for your help.

Post Reply