building my project in no errors but I can't see

CodeLite installation/troubleshooting forum
merena
CodeLite Curious
Posts: 1
Joined: Sun Apr 10, 2011 2:27 pm
Genuine User: Yes
IDE Question: c++
Contact:

building my project in no errors but I can't see

Post by merena » Sun Apr 10, 2011 2:41 pm

Building my project in no errors but I can't see,

I am using Ubuntu 10.4, CodeLite IDE run > Create new workspace > Create new project > Console > g++

Code: Select all

#include <stdio.h>

int main(int argc, char **argv)
{
	printf("hello world\n");
	return 0;
}
after, run(and i am ubuntu os not installed "wine") >

Image

thank you..

DavidGH
CodeLite Plugin
Posts: 690
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: building my project in no errors but I can't see

Post by DavidGH » Mon Apr 11, 2011 1:29 pm

Hi,

In the background of your image, it's possible to read some of gdb's output; this begins "No executable file specified..."

That means either that CodeLite's settings are wrong for building, so you didn't create an executable file; or, more likely, that they are wrong for debugging, so gdb isn't looking in the right place. Looking carefully at the output of Build, and earlier in the Debug output, should tell you which of these is the problem.

To cure the problem, you'll need to open the 'Project Settings' dialog and look at the settings. The 'new project' wizard will have provided something like:
Output File: $(IntermediateDirectory)/$(ProjectName)
Intermediate Folder: ./Debug
Program: ./$(ProjectName)
Working Folder: $(IntermediateDirectory)

If your settings look considerably different, try altering them.

Regards,

David

veiks81
CodeLite Curious
Posts: 1
Joined: Thu May 12, 2011 4:21 pm
Genuine User: Yes
IDE Question: c++
Contact:

Re: building my project in no errors but I can't see

Post by veiks81 » Thu May 12, 2011 4:49 pm

Just wanted to mention that what ever you do during installation one thing you should seriously consider is to have no spaces in your installation path. I'm currently also new in CodeLite users group and my first installation was more than ok, no errors what so ever, but after tons of successful project buildings there was actually non builded applications. Every time i hit F7 (build project) CodeLite shows green ok but there was still nothing to execute. So my fix was complete uninstall and reinstall to path with no single spaces. Now i'm happy user. :D

edit: I had my problems with spaces in path on windows 7 but no problems at all on ubuntu 10.04.

B.R.
Veiko
Last edited by veiks81 on Fri May 13, 2011 6:47 pm, edited 1 time in total.

User avatar
eranif
CodeLite Plugin
Posts: 6120
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: building my project in no errors but I can't see

Post by eranif » Thu May 12, 2011 5:43 pm

merena wrote:I am using Ubuntu 10.4, CodeLite IDE run
Your codelite version is very outdated .. (I think those icons were replaced 8 or maybe 9 months ago)

Any tip / suggestions I may give you here is useless unless you upgrade your codelite.

My advise:
Upgrade your codelite and try it. (one of the changes is that the xterm is no longer used for the console application output, instead codelite is using its own console)

Eran
Make sure you have read the HOW TO POST thread

Post Reply