Mysterious Error!

General questions regarding the usage of CodeLite

Mysterious Error!

Postby evstevemd » Thu Aug 19, 2010 7:39 pm

Hi,
I cannot compile DLL project no matter how hard I try it.
I have used both wx-enabled Dynamic library (Linux) and static.
I changed form Dynamic to static but nope! It don't work.
Strange enough, EXE works :shock:

I had CodeLite that comes with wx and I updated via SVN compilation.
g++, win XP SP3.
here is the error

----------Build Started--------
C:\WINDOWS\system32\cmd.exe /c ""mingw32-make.exe" -j 2 -f "Learn wxWidgets_wsp.mk""
----------Building project:[ testDLL - Debug ]----------

Please use the --wxcfg flag (as in wx-config --wxcfg=gcc_dll\mswud)
or set the environment variable WXCFG (as in WXCFG=gcc_dll\mswud)
to specify which configuration exactly you want to use.

Please use the --wxcfg flag (as in wx-config --wxcfg=gcc_dll\mswud)
or set the environment variable WXCFG (as in WXCFG=gcc_dll\mswud)
to specify which configuration exactly you want to use.
mingw32-make.exe[1]: Entering directory `D:/learn wxwidgets/Learn wxWidgets/testDLL'
g++: wx-config: No such file or directory
g++: Error:: Invalid argument
g++: No: No such file or directory
g++: valid: No such file or directory
g++: setup.h: No such file or directory
g++: of: No such file or directory
g++: wxWidgets: No such file or directory
g++: has: No such file or directory
g++: been: No such file or directory
g++: found: No such file or directory
g++: at: No such file or directory
g++: location:: Invalid argument
g++: C:\wxWidgets-2.8.10\lib\gcc_dll\mswd\wx\setup.h: No such file or directory
mingw32-make.exe[1]: *** [Debug/dialogsclass.o.d] Error 1
mingw32-make.exe[1]: Leaving directory `D:/learn wxwidgets/Learn wxWidgets/testDLL'
mingw32-make.exe: *** [All] Error 2
----------Build Ended----------
0 errors, 0 warnings
CodeLite 12.x
CodeLite is awesome, I just Love it!
evstevemd
CodeLite Guru
 
Posts: 329
Joined: Sun Nov 29, 2009 7:36 pm

Re: Mysterious Error!

Postby eranif » Thu Aug 19, 2010 7:43 pm

Can u also upload your project file?

Eran
Make sure you have read the HOW TO POST thread
User avatar
eranif
CodeLite Plugin
 
Posts: 5754
Joined: Wed Feb 06, 2008 9:29 pm

Re: Mysterious Error!

Postby frank_frl » Thu Aug 19, 2010 7:57 pm

Hi evstevemd,

you have configured your project to use the DLL version of wxWidgets, which seems not to exist on your computer. Maybe you have to build it first.

Frank
frank_frl
CodeLite Expert
 
Posts: 176
Joined: Sun Aug 17, 2008 2:45 pm

Re: Mysterious Error!

Postby evstevemd » Thu Aug 19, 2010 8:19 pm

@ Frank,
I have not got you.
I'm building a DLL file. When I build EXE it works but not DLL.
I might be doing something wrong but it is still mystery as I have checked all I could.

@ Eran, Here is a project with the files.
Thanks
You do not have the required permissions to view the files attached to this post.
CodeLite 12.x
CodeLite is awesome, I just Love it!
evstevemd
CodeLite Guru
 
Posts: 329
Joined: Sun Nov 29, 2009 7:36 pm

Re: Mysterious Error!

Postby eranif » Thu Aug 19, 2010 9:08 pm

evstevemd,

I suspect that the problem is that you are building the wrong configuration.
By looking at the .project file, it seems that 'Debug' is associated with the ANSI version of wxWidgets,

however, if you are using codelite's wx package, you only have the Unicode version.

The solution is simple:
Change the build configuration (from the combo box on top of the 'Workspace View') and build 'DebugUnicode' / 'ReleaseUnicode'

Eran
Make sure you have read the HOW TO POST thread
User avatar
eranif
CodeLite Plugin
 
Posts: 5754
Joined: Wed Feb 06, 2008 9:29 pm

Re: Mysterious Error!

Postby evstevemd » Thu Aug 19, 2010 9:42 pm

Cant see those options.
see below shots
You do not have the required permissions to view the files attached to this post.
CodeLite 12.x
CodeLite is awesome, I just Love it!
evstevemd
CodeLite Guru
 
Posts: 329
Joined: Sun Nov 29, 2009 7:36 pm

Re: Mysterious Error!

Postby frank_frl » Thu Aug 19, 2010 9:54 pm

You must change the setting for testDLL in Configuration Manager
You do not have the required permissions to view the files attached to this post.
frank_frl
CodeLite Expert
 
Posts: 176
Joined: Sun Aug 17, 2008 2:45 pm

Re: Mysterious Error!

Postby eranif » Thu Aug 19, 2010 9:56 pm

OK, so you only got 'Debug' / 'Release' for the workspace.

However, change it in the project level (open the 'drop down' for the project testDll and you will see it)
select it and click OK.

This will associate DebugUnicode configuration of project testDll with the workspace configuration 'Debug'

EDIT:

I noticed that Frank beat me :D

Anyways, read this for more information:

http://codelite.org/LiteEditor/ConfigurationManager

Eran
Make sure you have read the HOW TO POST thread
User avatar
eranif
CodeLite Plugin
 
Posts: 5754
Joined: Wed Feb 06, 2008 9:29 pm

Re: Mysterious Error!

Postby evstevemd » Fri Aug 20, 2010 8:45 am

Thanks guys,
Should I file feature request to force all projects in workspace to switch to a given config instead of changing each one manually?
CodeLite 12.x
CodeLite is awesome, I just Love it!
evstevemd
CodeLite Guru
 
Posts: 329
Joined: Sun Nov 29, 2009 7:36 pm

Re: Mysterious Error!

Postby eranif » Fri Aug 20, 2010 10:31 am

evstevemd wrote:Should I file feature request to force all projects in workspace to switch to a given config instead of changing each one manually?

No...

Whats that problem that you are having now? and why do you need to change each project manually ?

Eran
Make sure you have read the HOW TO POST thread
User avatar
eranif
CodeLite Plugin
 
Posts: 5754
Joined: Wed Feb 06, 2008 9:29 pm

Next

Return to Using CodeLite

Who is online

Users browsing this forum: No registered users and 8 guests

cron