Cannot debug using LLDB on macOS Mojave

General questions regarding the usage of CodeLite
pztrn
CodeLite Curious
Posts: 5
Joined: Mon Nov 12, 2018 8:13 pm
Genuine User: Yes
IDE Question: C++
Contact:

Cannot debug using LLDB on macOS Mojave

Post by pztrn » Mon Nov 12, 2018 9:44 pm

I'm trying to debug application with LLDB on macOS. Debug just not starting, yet just running works. Playing with parameters doesn't help. I 'm able to launch lldb manually from terminal and debug my app.

Versions:
OS: macOS Mojave 10.14.1
Codelite: 12.0.10 (downloaded from one of recent thread about fixing wxCrafter black background)
Compiler: Apple LLVM version 10.0.0 (clang-1000.11.45.5)
Debugger: lldb-1000.11.38.2

User avatar
eranif
CodeLite Plugin
Posts: 5855
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Cannot debug using LLDB on macOS Mojave

Post by eranif » Mon Nov 12, 2018 11:08 pm

Just tested this and I can successfully debug "hello world" test program on my Mac book.
Try increasing CodeLite log level (Preferences->Misc->Log->Developer) and try to debug again.
The log is written into ~/Library/Application Support/codelite/codelite.log
Make sure you have read the HOW TO POST thread

pztrn
CodeLite Curious
Posts: 5
Joined: Mon Nov 12, 2018 8:13 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Cannot debug using LLDB on macOS Mojave

Post by pztrn » Tue Nov 13, 2018 12:24 am

Thanks for hints, here's what I got:

Code: Select all

[01:10:50:537 DBG] [Main] codelite-lldb: could not create target for file /Users/pztrn/Projects/test/wxwidgets/SPG/cmake-build-$(WorkspaceConfiguration)/output/spgclient. unable to find executable for '/Users/pztrn/Projects/test/wxwidgets/SPG/cmake-build-$(WorkspaceConfiguration)/output/spgclient'
Looks like variables expanding problem?

User avatar
eranif
CodeLite Plugin
Posts: 5855
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Cannot debug using LLDB on macOS Mojave

Post by eranif » Tue Nov 13, 2018 2:56 am

Indeed. Can you try and change it manually from the project settings?

Replace the string $(WorkspaceConfiguration) with the actual configuration name (usually its Debug or Release)
Make sure you have read the HOW TO POST thread

pztrn
CodeLite Curious
Posts: 5
Joined: Mon Nov 12, 2018 8:13 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Cannot debug using LLDB on macOS Mojave

Post by pztrn » Tue Nov 13, 2018 8:28 am

Yes, that worked. Should I report this on Github?

Post Reply