Page 1 of 1

Can't download the plugin (codelite v2.0.3365)

Posted: Sun Dec 06, 2009 8:29 pm
by afrosimon

So I just downloaded codelite (looks like eclipse-cdt isn't working on ubuntu 9.10 X_X) and so far I find it's quite awesome. Much faster and lighter than eclipse... but I can't get to install the subversion plugin on the lastest version, I get this message while trying to install via aptitude :

Code: Select all

The following packages are BROKEN:
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 149kB of archives. After unpacking 508kB will be used.
The following packages have unmet dependencies:
  codelite-plugins-subversion: Depends: codelite (= 1.0.2893+dfsg-0ubuntu2) but 2.0.3365-ubuntu0 is installed.
The following actions will resolve these dependencies:

Downgrade the following packages:
codelite [2.0.3365-ubuntu0 (now) -> 1.0.2893+dfsg-0ubuntu2 (karmic)]

Score is 80
From what I've understand, it's isn't normal, any ideas why I can't get it to work with the lastest version?

Re: Can't download the plugin (codelite v2.0.3365)

Posted: Sun Dec 06, 2009 9:38 pm
by eranif
If you have downloaded codelite directly from sourceforge, then the plugin is already included

this plugin:

Code: Select all

If part of the codelite packaged by Ubuntu, not by me.

You can check to see if the plugin is installed from the menu:
Plugins > Manage plugins

In addition, you will need to install subversion client:

Code: Select all

sudo apt-get install subversion

Re: Can't download the plugin (codelite v2.0.3365)

Posted: Mon Dec 07, 2009 10:09 pm
by afrosimon
Oh yeah right, I didn't notice the first time, thanks.