Page 3 of 3

Re: Header not marked as changed

Posted: Sat Aug 23, 2008 9:18 pm
by frank_frl
For example:
In your previous post you mentioned the file

Code: Select all

Note how the last slash is forward slash and not backslash
While SVN reported this:

Code: Select all

All with backslashes

I added a fix to normalize the file name according to its platform hope this is the bug.
I don't think that this is the problem, the /frlbase was only on the command line when I invoked the svn command. SVN reports all paths in the windows way with a backslash, when you parse the project files, the path should be in the same format and why this appears only to the files in the include folder?

I've tried to compile a subversion.dll myself, but without success since my wxWidgets installation is different. My idea was to write the output, modifiedPaths and conflictedPaths arrays each to a wxTextFile to verify the contents. Maybe you can compile me such one.

You can send me the dll as a mail with attachment, I'll send you a PM with my address.


Just tried your new dll, no difference :cry: