Can't run anything.

Post here any ideas/problems/suggestions you have regarding CodeLite's Subversion (SVN) plugin

Can't run anything.

Postby Liuuks » Tue Mar 14, 2017 3:05 am

Hello!
I'm a Mac User and I have downloaded Codelite for University. At the beginning it works wonderfully but now (I do not know what I have delete/change) I can't run anything: all the "Build" command are grey (impossible to click). (I will put a screenshot if only knew how).
Trying do something I have receive this popup "Failed to locate gdb at 'gdb' " and looking in some forums I've try to change something in Settings->Build Settings->Tools but no solution. Also I've try to delete and reinstall Codelite but doesn't work. Now I'm using Xcode but I want to solve this problem with Codelite. :cry: :cry:
Liuuks
CodeLite Curious
 
Posts: 2
Joined: Tue Mar 14, 2017 2:40 am

Re: Can't run anything.

Postby eranif » Tue Mar 14, 2017 12:57 pm

If the tools are disabled ("grayed") it means that there is no workspace opened. Do you have a workspace open?
To take a screenshot, use CMD + SHIFT + 3 or CMD + SHIFT + 4 save it as PNG and attach it to the forum thread
Make sure you have read the HOW TO POST thread
User avatar
eranif
CodeLite Plugin
 
Posts: 5603
Joined: Wed Feb 06, 2008 9:29 pm

Re: Can't run anything.

Postby Liuuks » Wed Mar 15, 2017 1:48 am

Ok I finally solved this. I have to install Command Line Tool from Apple Developers sites. Thank you anyway for answering to my problem.
Liuuks
CodeLite Curious
 
Posts: 2
Joined: Tue Mar 14, 2017 2:40 am

Re: Can't run anything.

Postby eranif » Wed Mar 15, 2017 2:25 am

Note that you OSX, you should not use GDB as the debugger but rather select LLDB
This can be done from: Project settings->General->Debugger
Make sure you have read the HOW TO POST thread
User avatar
eranif
CodeLite Plugin
 
Posts: 5603
Joined: Wed Feb 06, 2008 9:29 pm


Return to Subversion

Who is online

Users browsing this forum: No registered users and 3 guests

cron