Codelite Won't Run. Config File Fails to Load.

CodeLite installation/troubleshooting forum
ahfriedm
CodeLite Curious
Posts: 2
Joined: Tue Feb 09, 2010 11:20 pm
Genuine User: Yes
IDE Question: C++
Contact:

Codelite Won't Run. Config File Fails to Load.

Post by ahfriedm » Thu Feb 11, 2010 5:47 am

Hi,

I was using Codelite with no problems for about a month until I updated my Laptop's BIOS. After that, my Codelite stopped working. It gives me this error when I try to run it:

20:43:49: XML parsing error: 'junk after document element' at line 215
20:43:49: Failed to load configuration file: C:\Program Files\CodeLite/config/codelite.xml

I've tried re-installing but it still doesn't work. I also tried using older versions.

I'm running Windows 7 on a Lenovo ThinkPad T500.

How can I fix this?

User avatar
eranif
CodeLite Plugin
Posts: 6056
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Codelite Won't Run. Config File Fails to Load.

Post by eranif » Thu Feb 11, 2010 9:57 am

Close codelite.
Delete the file 'C:\Program Files\CodeLite/config/codelite.xml'

Start CodeLite

Eran
Make sure you have read the HOW TO POST thread

ahfriedm
CodeLite Curious
Posts: 2
Joined: Tue Feb 09, 2010 11:20 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Codelite Won't Run. Config File Fails to Load.

Post by ahfriedm » Thu Feb 11, 2010 11:07 pm

Hi,

I deleted the file and tried to run it again, but it still didn't work. However, I noticed that when I tried to delete it Windows asked me to provide administrative credentials. I right clicked Codelite and went to "Run as Administrator" and Codelite booted up fine.

Thanks for the help!

Post Reply