Editor flagging 'endl' as 'undeclared identifier'

CodeLite installation/troubleshooting forum
wrsmith50
CodeLite Curious
Posts: 3
Joined: Fri Aug 14, 2020 3:04 am
Genuine User: Yes
IDE Question: C++
Contact:

Editor flagging 'endl' as 'undeclared identifier'

Post by wrsmith50 » Fri Aug 14, 2020 3:36 am

Why would the editor flag '#include <iostream>' as "file not found" and 'endl' as "Use of undeclared identifier". There is no problem with the usage as the system compiles and executes cleanly. The flag arrows get in the way when I'm running debugger. Running version 14.0.1. Is there a setting I'm missing?

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Editor flagging 'endl' as 'undeclared identifier'

Post by eranif » Wed Aug 19, 2020 11:30 pm

these errors are coming from the language server plugin.
some information on your codelite version and os could help here
Make sure you have read the HOW TO POST thread

wrsmith50
CodeLite Curious
Posts: 3
Joined: Fri Aug 14, 2020 3:04 am
Genuine User: Yes
IDE Question: C++
Contact:

Re: Editor flagging 'endl' as 'undeclared identifier'

Post by wrsmith50 » Thu Aug 20, 2020 1:23 am

I'm running Windows 10 Pro, Version 2004, OS Build 19041.388, Experience Pack 120.2202.130.0
64 bit OS

CodeLite version: amd64-14.01 (downloaded and installed July 17, 2020)
Development profile: C/C++ development
Using MinGW (mingw64) compiler
Path in environment: C:\Program Files\mingw-w64\mingw64\bin
Dark theme (Global theme RecognEyes)
C++ compiler options: -g;-O0;-std=c++17;-Wall

I'll be glad to provide additional specific information if needed

wrsmith50
CodeLite Curious
Posts: 3
Joined: Fri Aug 14, 2020 3:04 am
Genuine User: Yes
IDE Question: C++
Contact:

Re: Editor flagging 'endl' as 'undeclared identifier'

Post by wrsmith50 » Mon Aug 31, 2020 6:28 pm

Noted the online course I was taking was using version 14.0.0. I decided to remove the 14.0.1 version I was using and try the 14.0.0 version. I installed it exactly the same way as before and the problem disappeared. Someone at CodeLite should look to see what changed between the 2 versions.

Post Reply