Dependencies not satisfiable - Linux Mint Tara (Ubuntu 18.04 LTS)

CodeLite installation/troubleshooting forum
mpaninop
CodeLite Curious
Posts: 1
Joined: Mon Jun 24, 2019 5:35 am
Genuine User: Yes
IDE Question: C++
Contact:

Dependencies not satisfiable - Linux Mint Tara (Ubuntu 18.04 LTS)

Post by mpaninop » Mon Jun 24, 2019 6:02 am

I have been unsuccessful in running Codelite on my Linux Mint machine. The error messages is "error while loading shared libraries: libssh.so.4: cannot open shared object file. No such file or directory."

I am led to believe that libssh-dev is the library I need. However, attempting to install this leads to a Dependency not satisfiable error for libssh-4 (=0.8.7-1) Attempting to install that creates another dependency not satisfiable error: libgssapi-krb5-2(>=1.17) Attempting to install THAT creates yet another dependency error: Breaks existing package 'krb5-multidev' dependency libgssapi-krb5-2(= 1.16-2ubuntu0.1)

Anyone have any idea how to resolve all of these dependency issues?

DavidGH
CodeLite Plugin
Posts: 581
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: Dependencies not satisfiable - Linux Mint Tara (Ubuntu 18.04 LTS)

Post by DavidGH » Mon Jun 24, 2019 2:01 pm

Hi,

Not libssh-dev (unless you're trying to build CodeLite yourself), just libssh-4.

Sorry, that should have been in the debian/control file, so that it would have been installed automatically when you installed CodeLite.

Regards,

David

Post Reply