Ubuntu wxWidgets installation

CodeLite installation/troubleshooting forum
valiyuneski
CodeLite Enthusiast
Posts: 40
Joined: Fri Jul 11, 2008 11:13 pm
Contact:

Ubuntu wxWidgets installation

Post by valiyuneski » Thu Apr 25, 2019 1:33 pm

Hi Eran,

I have a problem with new Ubuntu 19.04 and wxWidgets 3.1.2 :

OS: XUbuntu 19.04
wxWidgets: wxwidgets3.1_3.1.2-1.disco.debian from your site downloaded and installed
(downloaded all 3.1.2-1.disco_amd64.deb and all 3.1.2-1.disco_all.deb
installed them with "sudo dpkg -i *.deb"

downloaded CodeLite-12.0.16-gtk2-ubuntu-bionic-x86_64
installed with "sudo dpkg -i CodeLite-12.0.16-gtk2-ubuntu-bionic-x86_64.deb")

It seems that wxWidgets installs badly on a fresh DiscoDebian machine since
when creating a simple wxWidgets Dialog Project comes up with the error:
"wx/wx.h no such file or directory"

Any Idea why ?

DavidGH
CodeLite Plugin
Posts: 585
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: Ubuntu wxWidgets installation

Post by DavidGH » Thu Apr 25, 2019 1:51 pm

Hi,

Yes, this was reported in https://github.com/eranif/codelite/issues/2263 and should now be fixed. Please apt update/upgrade, or download the 3.1.2-2 packages direct (it's actually only wx3.1-headers that has changed).

Regards,

David

Post Reply