Can't install Codelite IDE in Linux Mint Cinnamon 19.1

CodeLite installation/troubleshooting forum
faisal95
CodeLite Curious
Posts: 1
Joined: Sat Jan 12, 2019 8:33 pm
Genuine User: Yes
IDE Question: C++
Contact:

Can't install Codelite IDE in Linux Mint Cinnamon 19.1

Post by faisal95 » Sat Jan 12, 2019 8:36 pm

Hello guys. I'm using Linux Mint Cinnamon 19.1 64 bit.
I tried to install Codelite IDE. I've tried several processes to install it - from the terminal, from Mint software manager but I'm getting same errors.
Screenshots of errors I'm facing are given in the post.
You do not have the required permissions to view the files attached to this post.

DavidGH
CodeLite Plugin
Posts: 583
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: Can't install Codelite IDE in Linux Mint Cinnamon 19.1

Post by DavidGH » Sat Jan 12, 2019 9:12 pm

Hi,

That's strange. I just tested on a 19.1 cinnamon virtualbox guest; the distro's CodeLite 10.0 installed without problem, both from the Software Manager and synaptic. As the second error-message speculated, perhaps you have some other program(s) installed that depend on different versions of libclang1 etc.

One possible solution is for you to install CodeLite 12.0 from here. That also has the advantage that you get the latest release.

Regards,

David

Post Reply