wx-config: Command not found (and other path problems)

CodeLite installation/troubleshooting forum
Giansauna
CodeLite Curious
Posts: 2
Joined: Fri Oct 13, 2017 7:20 pm
Genuine User: Yes
IDE Question: C++
Contact:

wx-config: Command not found (and other path problems)

Post by Giansauna » Sat Dec 01, 2018 1:47 pm

I have just downloaded and installed CodeLite 12.0.10 to my Mac (Mojave 10.14.1). Because I'm new to CL, I tried to build simple apps from the GUI templates which are preconfigured in CL (i.e. choose a Gui template, select a destination path and click on the buttons without changing anything, ending up in the CL's editor).
But none of them work. I end up with error codes telling me about missing header files, missing wx-config, etc. Obviously none of the preconfigured paths in the GUI templates are correct. But why? I just dragged CL from the download folder to my App's folder.
How - and where - can I solve all this problems? I have read the FAQ in your Wiki, but my problem is not addressed there. I'm lost. Perhaps someone can give me some hints where to start to clean up this mess?

DavidGH
CodeLite Plugin
Posts: 582
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: wx-config: Command not found (and other path problems)

Post by DavidGH » Sat Dec 01, 2018 2:22 pm

Hi,

From the mention of wx-config, you are trying to build a project that uses, and depends on, the wxWidgets toolkit. Is it installed? If not you need to download, build and install it (unless there's a pre-built version available; I don't use OSX so I wouldn't know).

If it is already installed, maybe it's somewhere unusual. If so, you need to tell the CL project where it is, either by putting the /full/path/to/its/wx-config in the Compiler and Linker sections, or by specifying its PATH as an environmental variable.

Regards,

David

Giansauna
CodeLite Curious
Posts: 2
Joined: Fri Oct 13, 2017 7:20 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: wx-config: Command not found (and other path problems)

Post by Giansauna » Sat Dec 01, 2018 2:39 pm

Thank you, David. My mistake: I thought that wxWidgets toolkit is already included in CL because of the wxCrafter plugin, which is working fine (at least I can build a GUI with it in CL).

Post Reply