Having problem moving from 12.0.0 to .9

CodeLite installation/troubleshooting forum
shadowsocks
CodeLite Curious
Posts: 3
Joined: Thu Nov 09, 2017 8:04 am
Genuine User: Yes
IDE Question: c++
Contact:

Having problem moving from 12.0.0 to .9

Post by shadowsocks » Fri Nov 02, 2018 5:59 am

I have clicked "keep local settings" while installing 12.0.9, but when installation finished, I found that there seems to be no available themes for code highlighting.

All codes are displayed in plain text. Options in the status bar doesn't help. Settings->ColorsAndFonts shows an empty list of theme.

Does anyone know why? Thanks a lot.

User avatar
eranif
CodeLite Plugin
Posts: 5863
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Having problem moving from 12.0.0 to .9

Post by eranif » Sun Nov 04, 2018 12:54 am

Close CodeLite
Delete the folder %appdata%\codelite
and start it again
Make sure you have read the HOW TO POST thread

kroysoft
CodeLite Curious
Posts: 7
Joined: Thu Nov 15, 2018 12:40 am
Genuine User: Yes
IDE Question: PHP
Contact:

Re: Having problem moving from 12.0.0 to .9

Post by kroysoft » Thu Nov 15, 2018 12:45 am

Hi,

I have exactly the same problem while moving from 12.0.9 tp 12.0.10 today. Deleting appdata folder didn't help, unfortunately. Moreover, the setup wizard wants to run at every single start of codelite now - no matter what options I choose. How could I get back to 12.0.9? I can't find it anymore on download page and unfortunately I already deleted my copy few days ago. :(

User avatar
eranif
CodeLite Plugin
Posts: 5863
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Having problem moving from 12.0.0 to .9

Post by eranif » Thu Nov 15, 2018 1:45 am

You can only revert to 12.0
I suspect that the problem will not go away.
The fact the setup wizard wants to run means that there is some permissions problem somewhere on your machine.
What do you get the log file?
- increase the log level to DEBUG from Settings->Preferences->Misc->Log
- restart CodeLite and see what do you get in %appdata%\CodeLite\codelite.log
Make sure you have read the HOW TO POST thread

kroysoft
CodeLite Curious
Posts: 7
Joined: Thu Nov 15, 2018 12:40 am
Genuine User: Yes
IDE Question: PHP
Contact:

Re: Having problem moving from 12.0.0 to .9

Post by kroysoft » Thu Nov 15, 2018 11:51 am

Hi eranif,

first, I'd like to thank you for this great tool and for your answer as well! I really love codelite since I found it on the web back in 2012. And I always update to the latest weekly release as I also did it yesterday. However, I don't do this by the automatic update enabled, rather I used to check the homepage on regular basis in almost every week.

My problem is, that the IDE just worked flawless a minute or two before the update. I had no problem with it at all. It was v12.0.9 and I worked in it on my hobby project. Yesterday, the day before yesterday and so on. I really use it every day at home.

Then I updated to 12.0.10 and the themes disappeared suddenly and also the wizard started to bother me. At first start and at the next and now every time I start the IDE. So this is the problem.

After a quick search I found this topic and I tried what you've suggested to shadowsocks but that didn't helped. So temporary I switched back to 12.0.0 (as I didn't reach any later version) and it worked again (only VC10 build config became messed up a bit but this is another story and I could fix it easly). I hope I don't need to mention that keeping the current setting during installation was always my chose.

OK then, sorry for my long post. I'm just a bit sad because I lost the best working version 12.0.9. Never mind, I'll try what you've just suggested to get the log when I'll be home - and I'll be back with the results.

Thanks again and have a nice day!

User avatar
eranif
CodeLite Plugin
Posts: 5863
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Having problem moving from 12.0.0 to .9

Post by eranif » Thu Nov 15, 2018 1:56 pm

I am really interesting on what went wrong, as this might affect other people.
Can you please try the steps I listed in my previous post?

Also, here is a link to 12.0.9:
https://downloads.codelite.org/codelite ... -12.0.9.7z
Make sure you have read the HOW TO POST thread

kroysoft
CodeLite Curious
Posts: 7
Joined: Thu Nov 15, 2018 12:40 am
Genuine User: Yes
IDE Question: PHP
Contact:

Re: Having problem moving from 12.0.0 to .9

Post by kroysoft » Thu Nov 15, 2018 4:24 pm

That's great, thank you very much!

Of course, I'll try the steps suggested - in the evening when I'm home at earliest. I'll generate the logs you've asked for with both version if you like: v12.0.9 first and v12.0.10 after. I hope this will help.

kroysoft
CodeLite Curious
Posts: 7
Joined: Thu Nov 15, 2018 12:40 am
Genuine User: Yes
IDE Question: PHP
Contact:

Re: Having problem moving from 12.0.0 to .9

Post by kroysoft » Thu Nov 15, 2018 10:54 pm

Hi eranif,

I got news, I guess:

Yesterday I downgraded to 12.0.0. as I might already mentioned. So first, I changed the log level to "developer" as per your request and did a "clean" start of the application. I'm going to attach the resulting log.

Then I upgraded to the 12.0.9 version using that specific file what you've just linked recently. I kept the settings when this was asked by the installer. Then I left the launch checkbox in and ta-daa: I got the wizard which I thought I shouldn't... As this result was surprisng to me - because I"m 100% percent sure that I was already using that version before! So I started to insvestigate it and in the meanwhile it turned out that two days ago my W10 updated suddenly from build 1703 to 1803 - inspite the whole update system was definitely disabled! At least I did disable it all the way I could. I'm quite upset now, you just can't imagine...

Anyway, this fact could be in strong correlation with the issue - at least this is what I suspect now. And I found even more interesting things: after the first start of v12.0.9 the wizard came up, I skipped then closed the IDE (as I did with 12.0.0. before). Then I went to check the AppData and found that the following files became suddenly empty:

c:\Users\Károly\AppData\Roaming\codelite\config\abbreviations.conf 0 2018.11.15 18:56 -a--
c:\Users\Károly\AppData\Roaming\codelite\config\code-completion.conf 0 2018.11.15 18:56 -a--
c:\Users\Károly\AppData\Roaming\codelite\config\codelite.conf 0 2018.11.15 18:56 -a--
c:\Users\Károly\AppData\Roaming\codelite\config\docker.conf 0 2018.11.14 20:56 -a--
c:\Users\Károly\AppData\Roaming\codelite\config\php.conf 0 2018.11.15 18:56 -a--
c:\Users\Károly\AppData\Roaming\codelite\config\php-general.conf 0 2018.11.15 18:56 -a--
c:\Users\Károly\AppData\Roaming\codelite\config\plugins.conf 0 2018.11.15 18:56 -a--
c:\Users\Károly\AppData\Roaming\codelite\config\SmartCompletions.conf 0 2018.11.15 18:56 -a--
c:\Users\Károly\AppData\Roaming\codelite\config\svn-commit.conf 0 2018.11.15 18:56 -a--
c:\Users\Károly\AppData\Roaming\codelite\config\WebTools.conf 0 2018.11.15 18:56 -a--

It's strange, isn't it? I'm going to attach the new log as well, and you'll notice that the log level reverted to the default... One more thing I figured out: after I tried to delete these files and start codelite again (to see what will happen), first they were created with non zero size but then, after a while they become suddenly empty again.

So now I think I should find out which is the first version that will not work after W10 update. What's your opinion? Do you need any more information?
You do not have the required permissions to view the files attached to this post.

kroysoft
CodeLite Curious
Posts: 7
Joined: Thu Nov 15, 2018 12:40 am
Genuine User: Yes
IDE Question: PHP
Contact:

Re: Having problem moving from 12.0.0 to .9

Post by kroysoft » Thu Nov 15, 2018 11:07 pm

UPDATE: v12.0.8 from original source seems to work properly. I mean this is a backup copy of the installer downloaded from from https://downloads.codelite.org/ few weeks ago. I got it from one of my friend.

kroysoft
CodeLite Curious
Posts: 7
Joined: Thu Nov 15, 2018 12:40 am
Genuine User: Yes
IDE Question: PHP
Contact:

Re: Having problem moving from 12.0.0 to .9

Post by kroysoft » Tue Nov 20, 2018 5:38 pm

Hi eranif,

do you got any news on this topics, perhaps?
BTW I use 12.0.8. since then without issues - I'm just curious if you need any more info from my side.

Thanks!
Have a nice day!

Post Reply