Will not run

CodeLite installation/troubleshooting forum
Folken
CodeLite Curious
Posts: 8
Joined: Tue Apr 29, 2008 3:08 am
Location: 20688
Contact:

Will not run

Post by Folken » Tue Apr 29, 2008 3:18 am

running Ubuntu Gutsy. only goes as far as showing "starting codelite" in the window menu and then disappears. installed from a *.deb file rather than compiling from source. I'm rather new to linux so I still don't know how to compile from a source file.

http://i147.photobucket.com/albums/r306 ... enshot.png
--Folken Lacour de Fanel
Gutsy Ubuntu

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Will not run

Post by eranif » Tue Apr 29, 2008 9:23 am

Hi,

The reason for this is that CodeLite probably cant find the wx libraries.

try this:
From the terminal, type:

Code: Select all

export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
Now, I am assuming that the libwx* are installed under /usr/local/lib

after you typed this command, run (again, from the console):

Code: Select all

CodeLite &
If your libwx* are not installed under /usr/local/lib, you will need to search for them, running this will help you locate them:

Code: Select all

find / -name "libwx*"
Eran
Make sure you have read the HOW TO POST thread

Folken
CodeLite Curious
Posts: 8
Joined: Tue Apr 29, 2008 3:08 am
Location: 20688
Contact:

Re: Will not run

Post by Folken » Tue Apr 29, 2008 10:40 pm

Code: Select all

dave@dave-laptop:/home/dave# export LD_LIBRARY_PATH=/usr/local/lib:$LD_LIBRARY_PATH
dave@dave-laptop:/home/dave# CodeLite &
[1] 5782
dave@dave-laptop:/home/dave# CodeLite: /usr/lib/libwx_baseu-2.8.so.0: version `WXU_2.8.5' not found (required by CodeLite)

[1]+  Exit 1                  CodeLite
dave@dave-laptop:/home/dave# find / -name "libwx*"
/usr/share/lintian/overrides/libwxgtk2.8-0
/usr/share/lintian/overrides/libwxgtk2.6-0
/usr/share/lintian/overrides/libwxbase2.8-0
/usr/share/lintian/overrides/libwxbase2.6-0
/usr/share/doc/libwxgtk2.8-0
/usr/share/doc/libwxgtk2.6-0
/usr/share/doc/libwxbase2.8-0
/usr/share/doc/libwxbase2.6-0
/usr/lib/libwx_gtk2u_plot-2.6.so.0
/usr/lib/libwx_gtk2u_media-2.8.so.0
/usr/lib/libwx_gtk2u_stc-2.8.so.0.1.0
/usr/lib/libwx_gtk2u_qa-2.8.so.0
/usr/lib/libwx_gtk2u_media-2.8.so.0.1.1
/usr/lib/libwx_gtk2u_gl-2.8.so.0
/usr/lib/libwx_gtk2u_html-2.8.so.0
/usr/lib/libwx_gtk2u_animate-2.6.so.0.3.1
/usr/lib/libwx_baseu_net-2.8.so.0.1.1
/usr/lib/libwx_gtk2u_mmedia-2.8.so.0
/usr/lib/libwx_gtk2u_html-2.6.so.0
/usr/lib/libwx_gtk2u_plot-2.8.so.0.1.0
/usr/lib/libwx_gtk2u_aui-2.8.so.0
/usr/lib/libwx_gtk2u_svg-2.6.so.0
/usr/lib/libwx_baseu_xml-2.8.so.0.1.1
/usr/lib/libwx_baseu_net-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_qa-2.8.so.0.1.1
/usr/lib/libwx_gtk2u_ogl-2.8.so.0.1.0
/usr/lib/libwx_gtk2u_svg-2.8.so.0
/usr/lib/libwx_gtk2u_richtext-2.8.so.0.1.1
/usr/lib/libwx_gtk2u_ogl-2.6.so.0
/usr/lib/libwx_baseu_net-2.8.so.0
/usr/lib/libwx_gtk2u_gizmos_xrc-2.8.so.0.1.0
/usr/lib/libwx_gtk2u_stc-2.6.so.0
/usr/lib/libwx_gtk2u_deprecated-2.6.so.0
/usr/lib/libwx_gtk2u_fl-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_gizmos_xrc-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_adv-2.6.so.0.3.1
/usr/lib/libwx_baseu_net-2.6.so.0
/usr/lib/libwx_gtk2u_media-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_ogl-2.8.so.0
/usr/lib/libwx_gtk2u_richtext-2.8.so.0
/usr/lib/libwx_gtk2u_core-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_xrc-2.6.so.0
/usr/lib/libwx_baseu_xml-2.6.so.0
/usr/lib/libwx_gtk2u_xrc-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_gizmos-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_qa-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_media-2.6.so.0
/usr/lib/libwx_gtk2u_core-2.6.so.0
/usr/lib/libwx_gtk2u_svg-2.6.so.0.3.1
/usr/lib/vlc/gui/libwxwidgets_plugin.so
/usr/lib/libwx_gtk2u_xrc-2.8.so.0
/usr/lib/libwx_baseu-2.6.so.0
/usr/lib/libwx_baseu_xml-2.8.so.0
/usr/lib/libwx_gtk2u_deprecated-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_aui-2.8.so.0.1.1
/usr/lib/libwx_gtk2u_html-2.8.so.0.1.1
/usr/lib/libwx_gtk2u_adv-2.8.so.0
/usr/lib/libwx_gtk2u_stc-2.8.so.0
/usr/lib/libwx_gtk2u_fl-2.6.so.0
/usr/lib/libwx_gtk2u_plot-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_adv-2.8.so.0.1.1
/usr/lib/libwx_gtk2u_gizmos_xrc-2.6.so.0
/usr/lib/libwx_gtk2u_animate-2.6.so.0
/usr/lib/libwx_gtk2u_qa-2.6.so.0
/usr/lib/libwx_gtk2u_gl-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_gizmos-2.6.so.0
/usr/lib/libwx_gtk2u_core-2.8.so.0.1.1
/usr/lib/libwx_gtk2u_mmedia-2.8.so.0.1.0
/usr/lib/libwx_gtk2u_fl-2.8.so.0.1.0
/usr/lib/libwx_baseu-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_gizmos-2.8.so.0
/usr/lib/libwx_baseu-2.8.so.0
/usr/lib/libwx_gtk2u_fl-2.8.so.0
/usr/lib/libwx_gtk2u_html-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_plot-2.8.so.0
/usr/lib/libwx_gtk2u_xrc-2.8.so.0.1.1
/usr/lib/libwx_gtk2u_stc-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_ogl-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_mmedia-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_adv-2.6.so.0
/usr/lib/libwx_gtk2u_gl-2.6.so.0
/usr/lib/libwx_baseu_xml-2.6.so.0.3.1
/usr/lib/libwx_gtk2u_core-2.8.so.0
/usr/lib/libwx_baseu-2.8.so.0.1.1
/usr/lib/libwx_gtk2u_mmedia-2.6.so.0
/usr/lib/libwx_gtk2u_gl-2.8.so.0.1.1
/usr/lib/libwx_gtk2u_svg-2.8.so.0.1.0
/usr/lib/libwx_gtk2u_gizmos_xrc-2.8.so.0
/usr/lib/libwx_gtk2u_gizmos-2.8.so.0.1.0
/var/lib/dpkg/info/libwxbase2.6-0.md5sums
/var/lib/dpkg/info/libwxgtk2.8-0.md5sums
/var/lib/dpkg/info/libwxbase2.6-0.list
/var/lib/dpkg/info/libwxgtk2.8-0.shlibs
/var/lib/dpkg/info/libwxgtk2.8-0.postinst
/var/lib/dpkg/info/libwxbase2.8-0.postrm
/var/lib/dpkg/info/libwxgtk2.6-0.postinst
/var/lib/dpkg/info/libwxgtk2.6-0.list
/var/lib/dpkg/info/libwxgtk2.6-0.md5sums
/var/lib/dpkg/info/libwxbase2.8-0.list
/var/lib/dpkg/info/libwxgtk2.8-0.list
/var/lib/dpkg/info/libwxgtk2.6-0.postrm
/var/lib/dpkg/info/libwxgtk2.6-0.shlibs
/var/lib/dpkg/info/libwxbase2.6-0.shlibs
/var/lib/dpkg/info/libwxgtk2.8-0.postrm
/var/lib/dpkg/info/libwxbase2.8-0.postinst
/var/lib/dpkg/info/libwxbase2.8-0.shlibs
/var/lib/dpkg/info/libwxbase2.6-0.postinst
/var/lib/dpkg/info/libwxbase2.8-0.md5sums
/var/lib/dpkg/info/libwxbase2.6-0.postrm
/var/cache/apt/archives/libwxgtk2.8-0_2.8.4.0-0ubuntu3_i386.deb
/var/cache/apt/archives/libwxbase2.8-0_2.8.4.0-0ubuntu3_i386.deb
--Folken Lacour de Fanel
Gutsy Ubuntu

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Will not run

Post by eranif » Wed Apr 30, 2008 12:36 am

hi,

it looks like that the .deb file is not suitable for your box.

The provided .deb file, is using wx build as multilib and wx version 2.8.

What you can do, is build CodeLite by your self, it is not hard to do, just follow these instructions http://codelite.org/wiki/pmwiki.php?n=L ... r.Download

if you enoutered any error, you can post them here, and I will do my best to assist you.
Eran
Make sure you have read the HOW TO POST thread

Folken
CodeLite Curious
Posts: 8
Joined: Tue Apr 29, 2008 3:08 am
Location: 20688
Contact:

Re: Will not run

Post by Folken » Wed Apr 30, 2008 2:24 am

Code: Select all

 sudo svn co https://codelite.svn.sourceforge.net/svnroot/codelite/trunk codelite
svn: command not found

dave@dave-laptop:~$ sudo apt-get install libgtk2.0-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgtk2.0-dev is already the newest version.
libgtk2.0-dev set to manual installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
dave@dave-laptop:~$  sudo apt-get install libwxgtk2.8-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  libwxbase2.8-dev
Suggested packages:
  xlibmesa-gl-dev libgl-dev xlibmesa-glu-dev libglu-dev
The following NEW packages will be installed:
  libwxbase2.8-dev libwxgtk2.8-dev
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 76.3kB of archives.
After unpacking 311kB of additional disk space will be used.
Do you want to continue [Y/n]? 
Get:1 http://archive.ubuntu.com gutsy/universe libwxbase2.8-dev 2.8.4.0-0ubuntu3 [38.0kB]
Get:2 http://archive.ubuntu.com gutsy/universe libwxgtk2.8-dev 2.8.4.0-0ubuntu3 [38.4kB]
Fetched 76.3kB in 1s (48.4kB/s)          
Selecting previously deselected package libwxbase2.8-dev.
(Reading database ... 130153 files and directories currently installed.)
Unpacking libwxbase2.8-dev (from .../libwxbase2.8-dev_2.8.4.0-0ubuntu3_i386.deb) ...
Selecting previously deselected package libwxgtk2.8-dev.
Unpacking libwxgtk2.8-dev (from .../libwxgtk2.8-dev_2.8.4.0-0ubuntu3_i386.deb) ...
Setting up libwxbase2.8-dev (2.8.4.0-0ubuntu3) ...

Setting up libwxgtk2.8-dev (2.8.4.0-0ubuntu3) ...
--Folken Lacour de Fanel
Gutsy Ubuntu

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Will not run

Post by eranif » Wed Apr 30, 2008 7:45 am

Hi,

To get SVN, run this:

Code: Select all

sudo apt-get install subversion
Eran
Make sure you have read the HOW TO POST thread

Folken
CodeLite Curious
Posts: 8
Joined: Tue Apr 29, 2008 3:08 am
Location: 20688
Contact:

Re: Will not run

Post by Folken » Thu May 01, 2008 1:23 am

it works now... is there a tutorial to make it compile? (C++)
lately i've been using

Code: Select all

g++ -Wall code.cpp code2.cpp -o codeExe
while I don't mind coding and compiling through gedit and the console respectively, it would be nice if something could do it all in one.
--Folken Lacour de Fanel
Gutsy Ubuntu

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Will not run

Post by eranif » Thu May 01, 2008 8:19 am

Hi,

There is a tutorial, however it is not updated, so here is a short one instead:

1. Open CodeLite
2. Create new workspace, this is done from menu: Workspace -> Create Workspace, give it a name and path and click 'Create'
Image
3. Now you have a three cubes icon to the right, right click on it, and select 'Create New Project'
3. In the dialog that appears, select 'executable' as the project type, select the compiler to be g++, give the project a name (e.g. MyExe), path and click 'Create'
Image
4. Expand the 'Workspace' icon to the left, you should now see 2 directories: src, and include these area 'virtual folders', right click on the 'src' and select 'Add New Item'
Image
5. In the 'New Item' dialog, select the file to be 'C++' and give it a name 'main.cpp' click Ok.
6. A new file is added your project, main.cpp, write your code there, hit F7 (the hot key for 'build') and thats it.

Thats it.

Eran
Make sure you have read the HOW TO POST thread

Folken
CodeLite Curious
Posts: 8
Joined: Tue Apr 29, 2008 3:08 am
Location: 20688
Contact:

Re: Will not run

Post by Folken » Thu May 01, 2008 9:10 am

so it sorta works more like visual studio than dev c++
--Folken Lacour de Fanel
Gutsy Ubuntu

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Will not run

Post by eranif » Thu May 01, 2008 9:21 am

Folken wrote:so it sorta works more like visual studio than dev c++
More or less.

CodeLite is a mixture of eclipse & Visual Studio - the two IDEs I used to work with.

You will find many features that comes from the eclipse (like Quick Outline, Open Resource, Open Type and others) while the project management & build system is more like the visual studio.

Eran
Make sure you have read the HOW TO POST thread

Post Reply