gtk3?

CodeLite installation/troubleshooting forum

gtk3?

Postby jiapei100 » Thu Sep 14, 2017 9:41 am

Will codelite be using gtk3? instead of gtk2?

cheers
Pei
Welcome to Vision Open
http://www.visionopen.com
jiapei100
CodeLite Expert
 
Posts: 115
Joined: Wed Dec 30, 2009 8:29 am
Location: Surrey, BC, Canada

Re: gtk3?

Postby DavidGH » Thu Sep 14, 2017 1:19 pm

Hi,

On Linux, CodeLite is built against wxGTK, the Linux flavour of wxWidgets. wxGTK itself uses either gtk+2 or gtk+3, depending on the distro/version (or the whim of the self-builder).
CodeLite is perfectly happy with either gtk+2 or 3.

We provide unofficial CodeLite packages for the major distros, and use whichever gtk version is standard for that distro/version. So openSUSE packages currently use gtk+2; the fedora ones gtk+3.

Of course if you self-build wxGTK and CodeLite, you can use whichever gtk+ you prefer.

Regards,

David
DavidGH
CodeLite Plugin
 
Posts: 476
Joined: Wed Sep 03, 2008 7:26 pm


Return to Help

Who is online

Users browsing this forum: No registered users and 7 guests