The weekly build for Oct 03, 2015 is available

This forum is for the weekly builds only.
User avatar
eranif
CodeLite Plugin
Posts: 5927
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

The weekly build for Oct 03, 2015 is available

Post by eranif » Sun Oct 04, 2015 8:33 am

Hi,

The weekly build for Oct 03, 2015 is available and can be downloaded from the download page

The following packages are available:
  • Windows 64 bit
  • Windows 32 bit
  • OSX
  • Ubuntu 14.04/64 bit deb file
  • Debian 8 "Jessie" 64 bit deb file
To install the deb file:

Code: Select all

sudo apt-get purge codelite
sudo gdebi /path/to/codelite/deb/file
if you don't have gdebi, install it or use dpkg:

Code: Select all

sudo dpkg -i /path/to/codelite/deb/file
If you are facing some dependencies problems, purge any CodeLite version installed:

Code: Select all

sudo apt-get purge codelite
sudo dpkg -i /path/to/codelite/deb/file
Changes since last stable release can be found here:
http://codelite.org/LiteEditor/ReleaseNotesCodeLite83

Eran
Make sure you have read the HOW TO POST thread

DoctorRover
CodeLite Enthusiast
Posts: 21
Joined: Wed Feb 25, 2015 12:07 am
Genuine User: Yes
IDE Question: C++
Contact:

Re: The weekly build for Oct 03, 2015 is available

Post by DoctorRover » Wed Oct 07, 2015 2:22 am

Good day.
I tried to install this build in Ubuntu 15.04. Both gdebi and dpkg failed to install it. When I tried to do it using the Ubuntu Software Centre, it reported the following:
Lintian check results for /path/to/CodeLite-8.2.6-ubuntu-trusty-x86_64.deb:
E: codelite: control-file-has-bad-permissions md5sums 0664 != 0644
You're never too old to Rock'n'Roll if you're too young to die.

User avatar
eranif
CodeLite Plugin
Posts: 5927
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: The weekly build for Oct 03, 2015 is available

Post by eranif » Wed Oct 07, 2015 10:41 am

DoctorRover wrote:I tried to install this build in Ubuntu 15.04. Both gdebi and dpkg failed to install it
You should first:

Code: Select all

sudo apt-get purge codelite codelite-plugins wxcrafter
and then:

Code: Select all

sudo gdebi /path/to/file.deb
The mentioned error is because of CMake bad file permission generation (CodeLite uses CMake/CPack to generate the weekly build)
You can safely ignore these errors (there are others, I also ran linitian on the resulted deb)

Eran
Make sure you have read the HOW TO POST thread

DoctorRover
CodeLite Enthusiast
Posts: 21
Joined: Wed Feb 25, 2015 12:07 am
Genuine User: Yes
IDE Question: C++
Contact:

Re: The weekly build for Oct 03, 2015 is available

Post by DoctorRover » Wed Oct 07, 2015 2:08 pm

Eran, thank you for the answer.
I've purged the previous CL version before installing this one, as it was recommended in the first post, but not codelite-plugins and wxcrafter.
I'll try to remove them too.
You're never too old to Rock'n'Roll if you're too young to die.

User avatar
eranif
CodeLite Plugin
Posts: 5927
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: The weekly build for Oct 03, 2015 is available

Post by eranif » Wed Oct 07, 2015 2:28 pm

If you get an error, please post the error as well on your post
Eran
Make sure you have read the HOW TO POST thread

DoctorRover
CodeLite Enthusiast
Posts: 21
Joined: Wed Feb 25, 2015 12:07 am
Genuine User: Yes
IDE Question: C++
Contact:

Re: The weekly build for Oct 03, 2015 is available

Post by DoctorRover » Wed Oct 07, 2015 10:02 pm

It worked. After purging codelite-plugins and wxcrafter packages, this build has been installed successfully via gdebi.
Eran, thank you once again!
You're never too old to Rock'n'Roll if you're too young to die.

Post Reply