CodeLite 10.0.7 is forcing installaton of clang-format 3.5!

This forum is for the weekly builds only.

CodeLite 10.0.7 is forcing installaton of clang-format 3.5!

Postby Gnawme » Mon Sep 25, 2017 7:58 pm

Linux ubuntu 4.10.0-35-generic #39~16.04.1-Ubuntu SMP Wed Sep 13 09:02:42 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
Ubuntu 16.04
Currently using CodeLite IDE v10.0.6

I tried installing CodeLite v10.0.7, and it uninstalled clang-format 3.8 (on which my team is standardized) in favor of clang-format 3.5. The .clang-format config is not compatible between the two releases.

It also did other bad things to my installation that I don't remember. Thankfully, I'm using an Ubuntu VM, and I was able to restore my previous environment from a snapshot.

Can you possibly check if a version of clang-format > 3.5 is installed, and leave things alone if that's true?
Gnawme
CodeLite Curious
 
Posts: 1
Joined: Mon Sep 25, 2017 7:52 pm

Return to Weekly Builds

Who is online

Users browsing this forum: No registered users and 1 guest