Installation Problem - wxCrafter 1.2 (CodeLite 5.2)

Post here wxCrafter related issues / features / bugs
slaer
CodeLite Curious
Posts: 1
Joined: Sat Sep 07, 2013 1:19 pm
Genuine User: Yes
IDE Question: C++
Contact:

Installation Problem - wxCrafter 1.2 (CodeLite 5.2)

Post by slaer » Sat Sep 07, 2013 1:27 pm

Install the plugin. I choose to create a new project based on wxcrafter. There is a window

Image

User avatar
eranif
CodeLite Plugin
Posts: 5934
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Installation Problem - wxCrafter 1.2 (CodeLite 5.2)

Post by eranif » Sat Sep 07, 2013 4:38 pm

The way I see it this can happen if you installed the "standalone" version and not the plugin _or_
You installed the plugin, but did not restart codelite after the plugin installation


Eran
Make sure you have read the HOW TO POST thread

pavel.iqx
CodeLite Enthusiast
Posts: 19
Joined: Wed Jun 26, 2013 12:46 pm
Genuine User: Yes
IDE Question: c++
Contact:

Re: Installation Problem - wxCrafter 1.2 (CodeLite 5.2)

Post by pavel.iqx » Mon Sep 16, 2013 5:51 pm

I am sorry, but it doesn't work for me too. I am convinced that it happend after upgrading codelite from 5.1-2.wheezy to 5.2-1.wheezy. It's been quite a long time since upgrade and I noticed it yesterday, so excuse me if I am wrong.

This packages have been also upgraded:
libwxbase2.9-0-unofficial (2.9.4-1.wheezy) to 2.9.5-1.wheezy
libwxbase2.9-dev (2.9.4-1.wheezy) to 2.9.5-1.wheezy
libwxgtk2.9-0-unofficial (2.9.4-1.wheezy) to 2.9.5-1.wheezy
libwxgtk2.9-dev (2.9.4-1.wheezy) to 2.9.5-1.wheezy
wx-common (2.9.4-1.wheezy) to 2.9.5-1.wheezy
wx2.9-headers (2.9.4-1.wheezy) to 2.9.5-1.wheezy
wxcrafter (1.1-2.wheezy) to 1.2-1.wheezy
I've read sibling thread, but I don't understand where is the collision with wx, or so?
I'd like to have stable codelite from repo and using it to work on CL plugin - git version.

I'm really sorry, but I also don't undertand which wxCrafter to use with new CL 5.3?
If I'm not mistaken, standalone wxCrafter from http://downloads.codelite.org/wxCrafter/ is "too new" for wheezy's libc6 2.13-38.
Does CL from repo produce any logs? Or what logs should I provide?

me:

Code: Select all

$ lsb_release -d
Description:	Debian GNU/Linux 7.1 (wheezy)
$ uname -mrs
Linux 3.2.0-4-amd64 x86_64
Debian GNU/Linux 7.3 (wheezy) x64; CodeLite 5.4 from repo & CodeLite self-compiled from git HEAD

User avatar
eranif
CodeLite Plugin
Posts: 5934
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Installation Problem - wxCrafter 1.2 (CodeLite 5.2)

Post by eranif » Mon Sep 16, 2013 6:09 pm

pavel.iqx wrote:I'm really sorry, but I also don't undertand which wxCrafter to use with new CL 5.3?
Atm, there is a problem with using wxCrafter 1.2 and codelite 5.3

I have plans on releasing the standalone version of wxCrafter for all the *buntus this week (which are really standalone and have no link with codelite)
I can create a new virtual box for wheezy and create one for it as well, please check this thread in couple of days

Eran
Make sure you have read the HOW TO POST thread

pavel.iqx
CodeLite Enthusiast
Posts: 19
Joined: Wed Jun 26, 2013 12:46 pm
Genuine User: Yes
IDE Question: c++
Contact:

Re: Installation Problem - wxCrafter 1.2 (CodeLite 5.2)

Post by pavel.iqx » Mon Sep 16, 2013 6:39 pm

Thank you kindly.
Debian GNU/Linux 7.3 (wheezy) x64; CodeLite 5.4 from repo & CodeLite self-compiled from git HEAD

Post Reply