wxCrafter on opensuse 12.3

Post here wxCrafter related issues / features / bugs
Terchestor
CodeLite Curious
Posts: 2
Joined: Wed May 15, 2013 12:44 pm
Genuine User: Yes
IDE Question: c++
Contact:

wxCrafter on opensuse 12.3

Post by Terchestor » Wed May 15, 2013 1:28 pm

As reported in bug #890, wxcrafter doesn't load on openSUSE 12.3 because libwx_gtk2u_webview library is not found.
Here is my solution:
To avoid the libwx_gtk2u_webview-2.9.so.4 => not found when doing

Code: Select all

ldd /usr/lib64/codelite/wxCrafter.so
just do the following:
  • copy libwx_gtk2u_webview-2.9.so.4.0.0 from /usr/lib64/wx-2.9-wxcontainer/ to /usr/local/lib64/wx-2.9-wxcontainer/;
    link it as libwx_gtk2u_webview-2.9.so.4;
    do an ldconfig
You have to be superuser, of course!

Code: Select all

su
cp /usr/lib64/wx-2.9-wxcontainer/libwx_gtk2u_webview-2.9.so.4.0.0 /usr/local/lib64/libwx_gtk2u_webview-2.9.so.4.0.0
ln -s /usr/local/lib64/libwx_gtk2u_webview-2.9.so.4.0.0 /usr/local/lib64/libwx_gtk2u_webview-2.9.so.4
ldconfig
Then compile and install Codelite from sources (not from distro RPM package), and install wxCrafter.so in /usr/lib64/codelite/.
Hope it will work as it did for me ;)

User avatar
eranif
CodeLite Plugin
Posts: 5948
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: wxCrafter on opensuse 12.3

Post by eranif » Wed May 15, 2013 5:45 pm

I think that there was a bug for this on sourceforge and DavidGH already fixed it (or has plan on fixing it)
IIRC, the reason its broken is because openSUSE already comes with wx294. The next version will be compiled the wx that comes with openSUSE and this will save us this headache ;)

Eran
Make sure you have read the HOW TO POST thread

Terchestor
CodeLite Curious
Posts: 2
Joined: Wed May 15, 2013 12:44 pm
Genuine User: Yes
IDE Question: c++
Contact:

Re: wxCrafter on opensuse 12.3

Post by Terchestor » Wed May 15, 2013 6:48 pm

That's perfect. In the meanwhile, I can enjoy Codelite with wxCrafter, which I found really impressive.
I plan to redeploy an application writen for fltk and wxWidgets is IMO much better for this task than fltk was. Fluid was too buggy to be usefull and wxCrafter seems much more appealing for a complex software.
Thanks for this nice software :D

Manja
CodeLite Curious
Posts: 4
Joined: Thu Apr 25, 2013 11:36 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: wxCrafter on opensuse 12.3

Post by Manja » Thu May 16, 2013 11:37 am

i found this Packet not in SuSE Yast2:

libwx_gtk2u_webview-2.9.so.4.0.0

is this in other packet invisible?

Manja
CodeLite Curious
Posts: 4
Joined: Thu Apr 25, 2013 11:36 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: wxCrafter on opensuse 12.3

Post by Manja » Thu May 16, 2013 10:41 pm

Hello,
wxCrafter worked succesfully with SuSE 12.3

First must installed the libwebkitgtk-devel Library with Yast2
then wxWidgets 2.9.4 new compiled with

./configure --enable-webview
make
#as root:
make install
ldconfig

then the wxcrafter-1.1.1.x86_64.rpm install.

kind regards

Post Reply