undefined reference to wxC9ED9InitBitmapResources

Post here wxCrafter related issues / features / bugs
iwbnwif
CodeLite Veteran
Posts: 76
Joined: Thu Mar 21, 2013 1:12 pm
Genuine User: Yes
IDE Question: c++
Contact:

undefined reference to wxC9ED9InitBitmapResources

Post by iwbnwif » Sun Apr 28, 2013 5:25 pm

I am currently unable to compile on MSW because of this linker error.

I am sure it is something very simple but cannot find where this function is located.

I have tried a completely new project and workspace. A simple wxproject will compile fine. I only get this error when I start using external bitmaps

User avatar
eranif
CodeLite Plugin
Posts: 5944
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: undefined reference to wxC9ED9InitBitmapResources

Post by eranif » Sun Apr 28, 2013 6:07 pm

- Make sure that the file *_bitmaps.cpp is part of your project
- If the file exists, open it and make sure that the method at the bottom has the same name as the error
- If the file exists with different method name, delete the file and regenerate the code

One point to pay close attention:
- When selecting the root item in the tree view of wxC, in the properties view, make sure that the 'Output Directory' contains a relative path and not absolute path

Eran
Make sure you have read the HOW TO POST thread

iwbnwif
CodeLite Veteran
Posts: 76
Joined: Thu Mar 21, 2013 1:12 pm
Genuine User: Yes
IDE Question: c++
Contact:

Re: undefined reference to wxC9ED9InitBitmapResources

Post by iwbnwif » Sun Apr 28, 2013 11:38 pm

Thank you for such a fast response and sorry it has taken a while to get back but I really scratched my head about this.

In the end it turns out that if I add a bitmap whose pathname has a space in it then the wxcrafter_bitmaps.cpp does not get created properly.

I think this is a wxrc bug / limitation I read about somewhere, but missed the fact that wxC was using wxrc to create bitmaps.

evstevemd
CodeLite Guru
Posts: 330
Joined: Sun Nov 29, 2009 7:36 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: undefined reference to wxC9ED9InitBitmapResources

Post by evstevemd » Tue Jun 04, 2013 12:49 pm

I have same problem but slightly different. The bitmap cpp does not get generated at all
Here is my xrc file

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<resource xmlns="http://www.wxwindows.org/wxxrc" version="2.3.0.1">
  <object class="wxBitmap" name="debug-run">../../../../../.HosannaIDE/icons/oxygen-icons-4.7.4/16x16/actions/debug-run.png</object>
  <object class="wxBitmap" name="debug-run-cursor">../../../../../.HosannaIDE/icons/oxygen-icons-4.7.4/16x16/actions/debug-run-cursor.png</object>
</resource>
CodeLite 12.x
CodeLite is awesome, I just Love it!

User avatar
eranif
CodeLite Plugin
Posts: 5944
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: undefined reference to wxC9ED9InitBitmapResources

Post by eranif » Tue Jun 04, 2013 3:00 pm

- Check with the output directory of the wxCrafter project that the path to generate the files is correct.
- Try locating the the source file from the command line - see if you can locate it somewhere (maybe it was generated, but placed in a wrong location)

Eran
Make sure you have read the HOW TO POST thread

evstevemd
CodeLite Guru
Posts: 330
Joined: Sun Nov 29, 2009 7:36 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: undefined reference to wxC9ED9InitBitmapResources

Post by evstevemd » Tue Jun 04, 2013 3:07 pm

eranif wrote:- Check with the output directory of the wxCrafter project that the path to generate the files is correct.
- Try locating the the source file from the command line - see if you can locate it somewhere (maybe it was generated, but placed in a wrong location)

Eran
I will try to locate it but regarding paths see the atached shot
wxCL.png
You do not have the required permissions to view the files attached to this post.
CodeLite 12.x
CodeLite is awesome, I just Love it!

User avatar
eranif
CodeLite Plugin
Posts: 5944
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: undefined reference to wxC9ED9InitBitmapResources

Post by eranif » Tue Jun 04, 2013 4:30 pm

I assume that wxrc is installed on your machine?

Note: it is required by wxC, but this dependancy was removed in the soon to be released 1.2 version
Eran
Make sure you have read the HOW TO POST thread

evstevemd
CodeLite Guru
Posts: 330
Joined: Sun Nov 29, 2009 7:36 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: undefined reference to wxC9ED9InitBitmapResources

Post by evstevemd » Tue Jun 04, 2013 4:52 pm

eranif wrote:I assume that wxrc is installed on your machine?

Note: it is required by wxC, but this dependancy was removed in the soon to be released 1.2 version
Eran
Its not installed. I was about to suggest running the python script in utilities using boost.python when I saw the red color!
I will install and see if the problem is there!
CodeLite 12.x
CodeLite is awesome, I just Love it!

evstevemd
CodeLite Guru
Posts: 330
Joined: Sun Nov 29, 2009 7:36 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: undefined reference to wxC9ED9InitBitmapResources

Post by evstevemd » Tue Jun 04, 2013 4:52 pm

That was it!
Thanks a lot!
CodeLite 12.x
CodeLite is awesome, I just Love it!

Post Reply