Can't install wxCrafter on Debian 9.5

Post here wxCrafter related issues / features / bugs
Parduz
CodeLite Curious
Posts: 3
Joined: Tue Sep 18, 2018 12:18 pm
Genuine User: Yes
IDE Question: C++
Contact:

Can't install wxCrafter on Debian 9.5

Postby Parduz » Tue Sep 18, 2018 12:34 pm

Hello from Italy.
I'm a Windows programmer from about 20 years, who have to learn linux and his quirks in the last months, so please be patient with me if my question is stupid.

I have a project for a linux-embedded PC (a Beaglebone black) and for a year i've built the UI with the standalone wxCrafter on windows and compile the project on the BBB.

Now, i want to develop and build it on a Debian 9.5 PC and compile everything there.

So, using synaptic i've installed Codelite and Codelite-plugins, but did not see wxCrafter. So i've found this page and followed what it says, but still i can't find wxCrafter in any tab (or as an installed program).

So, i removed (purged) everything and now i'm ready to start again. What should i do? Or what have i done wrong?
DavidGH
CodeLite Plugin
Posts: 543
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: Can't install wxCrafter on Debian 9.5

Postby DavidGH » Tue Sep 18, 2018 1:30 pm

Hi,
Or what have i done wrong?

using synaptic i've installed Codelite and Codelite-plugin

Official debian splits Codelite into two packages, codelite and codelite-plugins. It sounds as though that's what you have installed at present.

However the current wxCrafter 2.9 package is built for our unofficial Codelite 12.0 build, not for the official debian Codelite 10.0. Those direct links are to the 64 bit packages, but you can install the packages with synaptic if you first add 'deb https://repos.codelite.org/debian/ stretch devel' to your /etc/apt/sources.list, update and select the unofficial codelite 12.0 and wxcrafter 2.9 packages (there isn't a separate plugins package, it's all-in-one). For more detail and options see http://codelite.org/LiteEditor/Repositories#toc1 and http://codelite.org/LiteEditor/Repositories#toc2.

Alternatively, if for some reason you prefer to use the official stretch 10.0 packages, the corresponding wxcrafter-2.7 from this archive page should still work, though I've not re-tested it recently.

Regards,

David
Parduz
CodeLite Curious
Posts: 3
Joined: Tue Sep 18, 2018 12:18 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Can't install wxCrafter on Debian 9.5

Postby Parduz » Tue Sep 18, 2018 1:55 pm

Thanks for your answer!


Yep, that's the page i followed to try.

DavidGH wrote:However the current wxCrafter 2.9 package is built for our unofficial Codelite 12.0 build, not for the official debian Codelite 10.0. Those direct links are to the 64 bit packages, but you can install the packages with synaptic if you first add 'deb https://repos.codelite.org/debian/ stretch devel' to your /etc/apt/sources.list, update and select the unofficial codelite 12.0 and wxcrafter 2.9 packages (there isn't a separate plugins package, it's all-in-one).




(re)doin' it as i write:

my current /etc/apt/sources.list:

Code: Select all

#

# deb cdrom:[Official Debian GNU/Linux Live 9.5.0 gnome 2018-07-14T17:23]/ stretch main

# deb cdrom:[Official Debian GNU/Linux Live 9.5.0 gnome 2018-07-14T17:23]/ stretch main

deb http://deb.debian.org/debian/ stretch main contrib
deb-src http://deb.debian.org/debian/ stretch main contrib

deb http://deb.debian.org/debian/ stretch/updates main contrib
deb-src http://deb.debian.org/debian/ stretch/updates main contrib

# stretch-updates, previously known as 'volatile'
deb http://deb.debian.org/debian/ stretch-updates main contrib
deb-src http://deb.debian.org/debian/ stretch-updates main contrib
deb https://repos.codelite.org/debian/ stretch devel
deb-src https://repos.codelite.org/debian/ stretch devel
deb http://repos.codelite.org/wx3.0.4/debian/ stretch libs
# deb-src http://repos.codelite.org/wx3.0.4/debian/ stretch libs


so i already have the repos.

This is what i get when i do the update in synaptic

Code: Select all

The repository 'http://deb.debian.org/debian stretch/updates Release' does not have a Release file.
Updating from such a repository can't be done securely, and is therefore disabled by default.
See apt-secure(8) manpage for repository creation and user configuration details.

http://security.debian.org/dists/stretch/updates/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.

http://deb.debian.org/debian/dists/stretch-updates/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.

http://repos.codelite.org/wx3.0.4/debian/dists/stretch/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.

Errore GPG: http://repos.codelite.org/wx3.0.4/debian stretch InRelease: Le seguenti firme non sono state verificate perché la chiave pubblica non è disponibile: NO_PUBKEY 6856E1DB1AC82609

The repository 'http://repos.codelite.org/wx3.0.4/debian stretch InRelease' is not signed.
Updating from such a repository can't be done securely, and is therefore disabled by default.
See apt-secure(8) manpage for repository creation and user configuration details.

http://deb.debian.org/debian/dists/stretch/Release.gpg: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.

https://repos.codelite.org/debian/dists/stretch/InRelease: The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key.

Errore GPG: https://repos.codelite.org/debian stretch InRelease: Le seguenti firme non sono state verificate perché la chiave pubblica non è disponibile: NO_PUBKEY 6856E1DB1AC82609
The repository 'https://repos.codelite.org/debian stretch InRelease' is not signed.


Searching for "codelite" results in the two 10.0 packages (codelite and codelite-plugins).


What should i do?
DavidGH
CodeLite Plugin
Posts: 543
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: Can't install wxCrafter on Debian 9.5

Postby DavidGH » Tue Sep 18, 2018 3:13 pm

The key(s) in the keyring /etc/apt/trusted.gpg are ignored as the file is not readable by user '_apt' executing apt-key

I use stretch and synaptic too, and I've not seen that error. However googling found this thread (see the last-but-two post) which suggests it's a synaptic bug. Try doing what it suggests:

Code: Select all

#> rm /etc/apt/trusted.gpg
#> apt update

However I had a quick look at the long debian thread that it refers to. That has some other opinions too...
Parduz
CodeLite Curious
Posts: 3
Joined: Tue Sep 18, 2018 12:18 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Can't install wxCrafter on Debian 9.5

Postby Parduz » Tue Sep 18, 2018 6:26 pm

Ok, removing the GPG files and then adding the codelite key worked, but messed up every other key, even with the reinstall of debian keyring, so i had to use this command

Code: Select all

sudo apt-key adv --keyserver ha.pool.sks-keyservers.net --recv-keys #######################

for each single missing key number. Now i have codelite and wxcrafter working, and synaptics/apt-get working again.

Thanks a lot.

Who is online

Users browsing this forum: No registered users and 2 guests