slovenian/croat keyboard layout problems.

Discussion about CodeLite development process and patches
Brane2
CodeLite Curious
Posts: 7
Joined: Sun Oct 05, 2014 2:09 am
Genuine User: Yes
IDE Question: C++
Contact:

slovenian/croat keyboard layout problems.

Post by Brane2 » Sun May 14, 2017 12:10 am

1. My config:
- Codelite 10.0, manually compiled ( but problem was present even in earlier versions)
-OS: Gentoo Linux 64 bit
- compiler: gcc-7.1.0 ( but the same result was even when compiled with gcc-6.3.0 or 5.4.0 or (clang/llvm)-4.0 and earlier)
-WM: if it is relevant, I use enlightenment-git+efl-git

2. Problem:

I can't get to some symbols at the keyboard when using Slovenian or Croatian layout, whereas on US layout symbols work fine.

Closing curly brace "}" is on SLO/CRO keyboards on AltGr+"n", but with Codelite, that produces nothing. I have to use AltGr+SHIFT+"n" for it to work.
That in itself would be tolerable, but pipe symbol "|", which is on those layouts AltGr+"w", doesn't work either. It just shows/hides my left workspace panel, just as if I pressed Ctrl+Alt+"w".

In just about every other app this works fine. I would simply deactivate the shortcut, but it is not listed in "Keyboard shortcuts", so...

DavidGH
CodeLite Plugin
Posts: 583
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: slovenian/croat keyboard layout problems.

Post by DavidGH » Sun May 14, 2017 2:06 pm

Hi,

I tested on debian jessie, kde, and confirm what you say. I was expecting it to be due to the wxWidgets toolkit that CodeLite uses, but it's not: neither the wx 'text' nor the 'stc' samples show this behaviour.

I can't help with AltGr+'n' (at least you have an easy workaround) but you can change the show/hide workspace shortcut using the 'Settings > Keyboard shortcuts' menu item. Type 'workspace' in the search field and 'View | workspace pane' is the last result. After removing the shortcut, AltGr+'w' produced the expected '|'.

Regards,

David

DavidGH
CodeLite Plugin
Posts: 583
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: slovenian/croat keyboard layout problems.

Post by DavidGH » Sun May 14, 2017 9:15 pm

Update: I just noticed that 'View > Navigation bar' has' ctrl-alt-n' as its shortcut. Though it closes the bar if it's open, for some reason it doesn't toggle properly, so AltGr+'n' seemed to do nothing.

After removing that, AltGr+'n' works too.

Post Reply