Page 1 of 1

Few issues with head

Posted: Tue Sep 30, 2014 4:55 am
by Gibbon1
I built the codelite /Head revision to check out the remote debugging stuff. This version I think ee7a4d48579434ad9289fb0b59d10bc84090b0ae

One thing I noticed is when a file gets modified outside the editor* a dialog comes up, with this version the buttons to either keep current or load the changed version are absent. (Dialog box is empty) I think it's loading the new version when you close the window.

* Because some idiot keeps using WinMerge to cut and paste between the AVR and ARM versions of the codebase to fix common bugs.

Maybe I should start a thread on remote debugging, but is there any reason why when recompiling, that you need to quit the debug session? I tend to just let my code run in the background as I'm making changes to the code.

Side thought: I didn't rebuild wxWidgets from the last time I built codelite 3-4 months ago, just saying.

Edit: The issue with the modified outside the editor button issue went away when I rebuilt everything with the latest version of wxWidgets and gcc 4.8.x

Re: Few issues with head

Posted: Tue Sep 30, 2014 5:01 am
by Gibbon1
Also from the using codelite thread

Tried building codelite (it complains about my older version of gcc 4.7.x vs 4.8.x (whatherewver)

But it appears to build okay, however when I ran update.bat I got a "The systems cannot find the file specified" for the following line

copy codelite-clang.exe "%TARGET_DIR%\CodeLite\" /Y

Looking there is no codelite-clang.exe in the Runtime folder. Hmmm.... codelite does start up.

This might be something to look into.