Clang support

Discussion about CodeLite development process and patches
User avatar
eranif
CodeLite Plugin
Posts: 6120
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Clang support

Post by eranif » Thu Nov 28, 2013 12:45 pm

kira.backes wrote:codelitegcc parses the passed arguments, puts them into compilation.db and then calls the passed arguments in a subshell. That’s how I understand it.
I meant: codelitegcc does not familiar with g++/clang/vc etc. It simply assumes that the first argument is the compiler name so it simply places the compilation line inside an intermediate file complation.db.txt (codelite moves the content of that file into the database, otherwise it will slow the compilation time)
kira.backes wrote:Yes it compiles, but code completion actually fails
This is strange. Since creating the PCH for the code completion involves the exact code as the code completion. It might be related to the fact the codelite uses its own libclang.dll so this version might be a bit older than the one you are using for compilation

Can you provide the error you get?

Eran
Make sure you have read the HOW TO POST thread

kira.backes
CodeLite Curious
Posts: 9
Joined: Wed Nov 13, 2013 4:25 pm
Genuine User: Yes
IDE Question: C++
Location: Germany → NRW
Contact:

Re: Clang support

Post by kira.backes » Thu Nov 28, 2013 3:00 pm

Hello,


I thought the bundled libclang is only used in Windows but there’s also a bundled libclang.so in the linux package. Since I can not copy the error message directly (the text is not selectable, I think this is a bug), I made a screenshot instead:
clang-completion-error.jpg

rgds, Kira
You do not have the required permissions to view the files attached to this post.

User avatar
eranif
CodeLite Plugin
Posts: 6120
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Clang support

Post by eranif » Thu Nov 28, 2013 3:56 pm

What happens when you enable C++11 flag for clang code completion?
Right click on the Workspace icon -> Workspace Settings -> Code Completion -> Enable C++11 Standard (clang)

Does it help?
Eran
Make sure you have read the HOW TO POST thread

Post Reply