Space ignored in editor

General questions regarding the usage of CodeLite
riri
CodeLite Curious
Posts: 2
Joined: Wed Aug 20, 2008 11:05 am
Contact:

Space ignored in editor

Post by riri » Wed Aug 20, 2008 11:13 am

Hi

I'm testing the IDE, and the features seems to be interesting. However, I've a problem in the source code editor: the space key doesn't work. In fact, it seems to act as if I would press Ctrl+space (but I'm sure it's not the case). When no completion is available, this does nothing; in the other case, this brings the completion popup list.

I tried first with the latest SVN version (in trunk) that I built, and then with the latest Ubuntu deb package (revision 1789), because I thought it was a 'trunk break'. I'm on an Ubuntu 8.04 system.

Any idea ?

User avatar
eranif
CodeLite Plugin
Posts: 5983
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Space ignored in editor

Post by eranif » Wed Aug 20, 2008 11:33 am

This is not a CodeLite related problem, but rather a Ubuntu with french keyboard layout bug:

https://bugs.launchpad.net/ubuntu/+sour ... omments/14

More information can be found here:
http://forums.codeblocks.org/index.php/ ... 291.0.html

Eran
Make sure you have read the HOW TO POST thread

riri
CodeLite Curious
Posts: 2
Joined: Wed Aug 20, 2008 11:05 am
Contact:

Re: Space ignored in editor

Post by riri » Wed Aug 20, 2008 12:36 pm

Thanks for reply

I used the XkbOptions fix, which worked fine:

Code: Select all

Option "XkbOptions" "nbsp:none"
Will try more the IDE in the next days ;-)

User avatar
eranif
CodeLite Plugin
Posts: 5983
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Space ignored in editor

Post by eranif » Wed Aug 20, 2008 1:06 pm

riri wrote:I used the XkbOptions fix, which worked fine
Good news
riri wrote:Will try more the IDE in the next days
Please use the latest SVN (contains many bug fixes and enhancements)

Eran
Make sure you have read the HOW TO POST thread

Post Reply