search for CMake in Windows

General questions regarding the usage of CodeLite
amwink
CodeLite Curious
Posts: 8
Joined: Mon Jun 08, 2020 4:04 pm
Genuine User: Yes
IDE Question: c++
Contact:

search for CMake in Windows

Post by amwink » Tue Aug 25, 2020 11:36 pm

After installing CodeLite 14.0.2 on a virtual Windows 7 computer at work (no root privileges so installed/downloaded to a network drive) and having MinGW gcc-8.1.0 and CMake 3.18.2 non-root installed the same way in neighbouring directories, I failed to set up the CMake build system and to keep the compiler setting.

The compilers are not recognised automatically, but I can add the compilers by selecting the main directory of MinGW, and all the necessary tools are then automatically detected. After closing CodeLite and restarting, the MinGW compilers are still there. However, after logging out it goes back to a blank setup.

In the 'build systems' section I can choose from a drop-down menu between the three choices provided in this version, but there is no way to browse or search for CMake.

Does anyone know
-- if it is possible to save the CodeLite preferences in a safe, non-administrator-privileges place so that they are saved in a user installation?
-- if it is possible to add the CMake build system manually (which I presume is not detected if it's not in the system path)?

Many thanks!

User avatar
eranif
CodeLite Plugin
Posts: 6110
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: search for CMake in Windows

Post by eranif » Tue Sep 01, 2020 12:31 pm

CodeLite preferences are kept under %appdata%\CodeLite -> this is a user location and you should have write access to this folder.
I wonder if logging out caused CodeLite terminate abnormally which causes a configuration file corruption.

The CMake build system is there if you have the CMake plugin installed (you should have it)
You then need to install CMakePlugin (CodeLite does not do that for you), once installed, you can set the proper path to CMake from: Pugins -> CMake -> Settings
Make sure you have read the HOW TO POST thread

Post Reply