Page 1 of 1

Can't Enter Compiler Settings CodeLite 13.0.0

Posted: Thu Jun 27, 2019 11:00 pm
by ColleenKobe
I just loaded CodeLite version 13.0.0. In the installation process, it asked if I wanted to keep my current settings. I said yes.

But when I loaded my Workspace and tried to compile, my compiler settings were gone.

So I clicked on my project, and then on the menu bar clicked Settings, and scrolled to the Tools Tab. All the fields on that page were empty.

I am using MinGW for my compiler, and entered the settings as shown in the image below.
codelite settings.jpg
When I was done and clicked OK, CodeLite crashed--the program was just GONE. I started over and returned to the Build Settings page with the Tools tab open. All those fields were empty again.

What am I doing wrong?

I tried to find posts from anyone else who may have had this error, but I couldn't find any.

Also, when I click <ctrl> <shift> R, wxCrafter doesn't show up any more. How do I get it back?


C++ and C
CodeLite 13.0.0
wxCrafter 2.9
Windows 10, 64-bit

Re: Can't Enter Compiler Settings CodeLite 13.0.0

Posted: Sat Jun 29, 2019 11:47 am
by eranif
If you will notice, for some reason the compiler name is empty.
Click the duplicate button (the one next to the + sign)
Copy the current compiler and give it a name
Use that compiler in your settings

Re: Can't Enter Compiler Settings CodeLite 13.0.0

Posted: Wed Jul 03, 2019 3:18 pm
by ColleenKobe
Thank you for replying.

I filled in the blanks with the settings above. I clicked the Duplicate button, named the new Compiler Settings group MinGW, and clicked OK. The New Compiler window went away, all looked fine for a moment, and then CodeLite went away. Crashed, I guess. When I brought it up again and went to the Build page, the fields were all empty and the compiler name box was also empty.

I've tried this approach without filling out any of the fields before trying to save the compiler settings as a duplicate. CodeLite still goes away.


Re: Can't Enter Compiler Settings CodeLite 13.0.0

Posted: Wed Jul 03, 2019 9:40 pm
by ColleenKobe
Okay. I got it. I created a new Workspace and rebuilt the entire workspace step by step. It took a few hours but I'm very happy it works.

Thank you!