gentoo - compile of codelite-git fails...

General questions regarding the usage of CodeLite
Brane212
CodeLite Curious
Posts: 3
Joined: Mon Jun 18, 2018 1:01 pm
Genuine User: Yes
IDE Question: C++
Contact:

gentoo - compile of codelite-git fails...

Post by Brane212 » Fri Aug 24, 2018 10:54 am

...with

/var/tmp/portage/dev-util/codelite-9999/work/codelite-9999/Plugin/drawingutils.cpp:998:55: error: ‘wxCONTROL_NONE’ was not declared in this scope
I there some special requirement for wxGTK ?

I have wxGTK in versions 3.0.4 and 3.0.4 compiled for gtk3, but no matter which one I e-select, codelite-9999 compile always fails...

DavidGH
CodeLite Plugin
Posts: 573
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: gentoo - compile of codelite-git fails...

Post by DavidGH » Fri Aug 24, 2018 1:24 pm

Hi,

The most recent CodeLite git needs to be built against wx3.1; and preferably against the patched 3.1 from https://github.com/eranif/wxWidgets/.

CodeLite was suffering from flicker when using gtk+3. IIUC the latest wx git has some workarounds, and there are more in https://github.com/eranif/wxWidgets/. However these fixes mean that CodeLite currently fails to build against earlier wx releases.

That will change if the patch from this bug-report are accepted. CodeLite would then build again with wx3.0.4; however flicker would still be a problem with a gtk+3 wx3.0.4.

Until that happens your choices are:
  • Build your own wx3.1, preferable the fixed version.
    Revert to a CodeLite from several days ago; I think #625a36fa2 would be OK.
    Use your wx3.0.4, but apply to the latest CodeLite the patch from that bug-report.
Regards,

David

Brane212
CodeLite Curious
Posts: 3
Joined: Mon Jun 18, 2018 1:01 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: gentoo - compile of codelite-git fails...

Post by Brane212 » Fri Aug 24, 2018 3:02 pm

Ah, zo...

I've found zugaina ovverlay with ebuild for wxwidgets-3.1.1-r301:3.1-gtk3

It works now.

Thanks.

Post Reply