how to disable code completion?

General questions regarding the usage of CodeLite
DaveHarper
CodeLite Curious
Posts: 3
Joined: Sun Aug 28, 2016 6:20 am
Genuine User: Yes
IDE Question: C++
Contact:

how to disable code completion?

Post by DaveHarper » Sat Apr 21, 2018 10:49 pm

I realize this may border on the heretical, but is there any way to disable this feature? I'm a touch typist and I already know what I'm trying to type so I'm watching the screen. However, most of the time what I'm trying to type is being covered up by the code completion windows. This is slowing me down so much that I've had to resort to using an external editor. I've tried removing the path in PHP->Code Completion, disabling the word completion plugin and turning off the Smart Completions plugin. Nothing seems to completely turn off these "helpful popups". Is there any way to accomplish this?

Dave

User avatar
eranif
CodeLite Plugin
Posts: 5995
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: how to disable code completion?

Post by eranif » Wed Apr 25, 2018 10:14 am

Which version of CodeLite? OS? and which language?
Thanks!

PS: You can't do this in general, however, you can reduce the number of popups by disabling the option: "Settings->Code Completions->Triggering->Auto display code completion box ..."
Will this option disabled, code completion will only appear when you type "->" or "."
Make sure you have read the HOW TO POST thread

DaveHarper
CodeLite Curious
Posts: 3
Joined: Sun Aug 28, 2016 6:20 am
Genuine User: Yes
IDE Question: C++
Contact:

Re: how to disable code completion?

Post by DaveHarper » Wed Apr 25, 2018 1:26 pm

Sorry - I should have mentioned that - the CodeLite version is 12.0.0, the OS is Linux Mint and the language is C/C++. I just tried your suggestion and it looks like it covers the cases I tried. I do use structs a lot so the "->" and "." cases will occur, but I can live with that. Thanks for the pointer!

Dave

Post Reply