Can't see wxString values in Debugger

General questions regarding the usage of CodeLite
ColinTaylor
CodeLite Expert
Posts: 152
Joined: Fri Jul 15, 2011 2:49 pm
Genuine User: Yes
IDE Question: C++
Contact:

Can't see wxString values in Debugger

Post by ColinTaylor » Tue Jan 16, 2018 4:51 pm

Windows 10 (64-bit) / Codelite 11.0.7 / wxWidgets 3.1 / TDM-GCC-4.9.2

Occasionally, the debugger doesn't show the values of wxString objects. I'll attach a screenshot once I know how to :cry:

I'll try and show an example of how it appears...

Code: Select all

      const wxString PhotoFullFileName = m_PhotoFileList.GetFullFileName (m_CurrentPhotoId);

      // loading via stream is *marginally* quicker than from file
[b]>>> Breakpoint here >>>[/b]      wxFileInputStream FileInputStream (PhotoFullFileName);
      m_CurrentImage.LoadFile (FileInputStream);
      if (m_CurrentImage.IsOk())
      {
Debugger window (the window with tabs "Locals", "Watches", "Callstack" etc) displays the following
  • Name Value
    PhotoFullFileName {...}
I've tried things like refreshing the Debugger Window, and was wondering if there's a setting I need to change to make the string value appear.
This doesn't happen with every wxString, and I haven't found a way to guarantee reproducing the issue either.
Sadly I can't readily upload a sample project to illustrate the issue, as small projects don't seem to suffer from this issue, and the project I'm working in is too large with too many dependencies to be easily uploaded.

If anyone has any suggestions, they'd be much appreciated!
Thanks, Colin
You do not have the required permissions to view the files attached to this post.

marcelinux
CodeLite Enthusiast
Posts: 17
Joined: Mon Nov 02, 2015 3:26 pm
Genuine User: Yes
IDE Question: C++
Location: Spain
Contact:

Re: Can't see wxString values in Debugger

Post by marcelinux » Thu Feb 01, 2018 12:16 pm

I think Debugger do not show const values. Only variables

ColinTaylor
CodeLite Expert
Posts: 152
Joined: Fri Jul 15, 2011 2:49 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Can't see wxString values in Debugger

Post by ColinTaylor » Thu Feb 01, 2018 1:03 pm

Many thanks for the suggestion; I shall investigate further :D
Colin

Post Reply