Unable to debug using LLDB

General questions regarding the usage of CodeLite
mnemonic
CodeLite Enthusiast
Posts: 12
Joined: Thu Sep 08, 2016 1:45 pm
Genuine User: Yes
IDE Question: C++
Contact:

Unable to debug using LLDB

Post by mnemonic » Sun Oct 22, 2017 8:29 am

OS: Kubuntu 17.10 (fresh install)
CodeLite Version: 11.0.0 (installed from repository)
LLDB version: 4.0.1
Clang version: 4.0.1

I'm not able to debug using the LLDB debugger. When I press F5 to start the debugger, the terminal shows very briefly, then just disappears. Any breakpoints I set are also removed.

If I right-click on the project and set SETTINGS > GENERAL > DEBUGGING > DEBUGGER to GNU gdb debugger, then I am able to step through the simple default "Hello World" generated project (I haven't tried with larger projects) and everything seems to work fine.

Any help would be really appreciated.

DavidGH
CodeLite Plugin
Posts: 583
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: Unable to debug using LLDB

Post by DavidGH » Sun Oct 22, 2017 11:04 am

Hi,

Yes. When I create linux packages for a new CodeLite/new distro release, I always test lldb and it often behaves like that, especially in 32-bit builds. Sometimes it's worse: there was one release where I had actually to prevent lldb 3.7 from being used as it crashed CodeLite!

As different lldb versions seem to vary considerably, and it isn't exactly core for linux, I no longer waste time trying get every version to work. I just use gdb.

Regards,

David

mnemonic
CodeLite Enthusiast
Posts: 12
Joined: Thu Sep 08, 2016 1:45 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Unable to debug using LLDB

Post by mnemonic » Sun Oct 22, 2017 4:24 pm

Hi DavidGH - thank you so much for the reply (and explanation). Just one more quick question - is it okay to use GDB for projects built with clang++?

DavidGH
CodeLite Plugin
Posts: 583
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: Unable to debug using LLDB

Post by DavidGH » Sun Oct 22, 2017 9:08 pm

I don't see why not. And on a quick check with my own program, the combination does seem to work.

Please post if you find otherwise.

User avatar
eranif
CodeLite Plugin
Posts: 5934
Joined: Wed Feb 06, 2008 9:29 pm
Genuine User: Yes
IDE Question: C++
Contact:

Re: Unable to debug using LLDB

Post by eranif » Sun Oct 29, 2017 10:07 pm

FYI: there was a bug introduced in CodeLite 11.
Which is now fixed in git master.

I will be releasing CodeLite 11.0.3 today with the fix included
Make sure you have read the HOW TO POST thread

Post Reply