code completion stops working between ubuntu versions?

General questions regarding the usage of CodeLite
amwink
CodeLite Enthusiast
Posts: 10
Joined: Mon Jun 08, 2020 4:04 pm
Genuine User: Yes
IDE Question: c++
Contact:

code completion stops working between ubuntu versions?

Post by amwink » Wed Feb 24, 2021 1:09 pm

Just wondering if anyone else has had this issue.

After upgrading from Ubuntu 18 to 20, CodeLite code completion has not worked.
This goes for c++ standard (library) functions as well as ones in my own workspace.

I did see in
settings -> code completion -> CTags -> search paths
that it still looked for g++ 7, where after the upgrade it was 9.

So I changed those paths but that did not fix it (and would not have made any difference for my own workspace functions)

Does anyone know a setting that may have / should be changed?
As far as I can see CodeLite has not changed over the upgrade.

DavidGH
CodeLite Plugin
Posts: 702
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: code completion stops working between ubuntu versions?

Post by DavidGH » Wed Feb 24, 2021 2:05 pm

Hi,

Which CodeLite version(s) are you using, and where from? Self-builds, the official ubuntu packages, or our unofficial ones?

One possible reason is that you're missing libncurses5; see https://github.com/eranif/codelite/issues/2679.

Regards,

David

amwink
CodeLite Enthusiast
Posts: 10
Joined: Mon Jun 08, 2020 4:04 pm
Genuine User: Yes
IDE Question: c++
Contact:

Re: code completion stops working between ubuntu versions?

Post by amwink » Thu Feb 25, 2021 1:54 pm

Hi David, thanks for the reply and sorry to be a bother.

I'm using the ubuntu repo

Code: Select all

deb [arch=amd64] https://repos.codelite.org/ubuntu/ focal universe # disabled on upgrade to focal
but doing a 'grep' for that in my 'sources.list' I first noticed the comment at the end...
And lo and behold, when I did another check with the package manager, codelite upgraded and the predictor works again!
Nothing was shown about ncurses being upgraded at the same time, but then it doesn't have its own line in the sources file.

Code: Select all

$ codelite -v
CodeLite IDE v15.0.0
$ ncurses6-config --version
6.2.20200212
$ ncurses5-config --version
6.2.20200212
That last one is interesting...

bw
Alle Meije

DavidGH
CodeLite Plugin
Posts: 702
Joined: Wed Sep 03, 2008 7:26 pm
Contact:

Re: code completion stops working between ubuntu versions?

Post by DavidGH » Thu Feb 25, 2021 2:24 pm

codelite upgraded and the predictor works again!
Good.
ncurses5-config --version
6.2.20200212
I don't understand the significance of that, but the important thing is that libncurses5.so.* exists and points to something sensible. Code-completion does also work with libncurses6; it's just that it tries to link only to 5.

BTW, a good way to see if libncurses5 is installed is:

Code: Select all

apt policy libncurses5 | grep Installed

Post Reply